Click here to Skip to main content
15,747,059 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more: , +
I am developing an ASP.NET application using MS VS 2013 and MS SQL Server 2014. When i start ASP.NET Web Site Administration Tool by CMD and click on security tab, I get below error:

" There is a problem with your selected data store. This can be caused by an invalid server name or credentials, or by insufficient permission. It can also be caused by the role manager feature not being enabled. Click the button below to be redirected to a page where you can choose a new data store.

The following message may help in diagnosing the problem: Unable to connect to SQL Server database. "

my web.config setting:

    <add name="newsdbConnectionString"
     connectionString="Data Source=(LocalDB)\v11.0;AttachDbFilename=|DataDirectory|\newsdb.mdf;Integrated Security=True;Connect Timeout=30"
  providerName="System.Data.SqlClient" />
    <compilation debug="true" targetFramework="4.5">
        <add assembly="System.Data.Linq, Version=, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
    <httpRuntime targetFramework="4.5"/>

What is the problem .
Updated 4-Jan-15 19:54pm

1 solution

Check your credentials once again.
And your .mdb file should be present in the project folder as described in your path.
Share this answer

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900