Click here to Skip to main content
15,039,214 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
Hi,
Having problem to localize custom controls in silverlight.
Here goes the scenario:

One project (silverlight 4) where custom controls are kept.
This controls are localize by using resource files, bindings from xaml/Static resource. These controls are loaded from different projects (this is also localized and working ok).
But the localization of the controls are not working.
I have done the following things to find out the prob:
- Confirm it gets the correct UI Culture
- Binding seems ok as English (default) is working ok
- Resources Build Action - Embeded Resource
- Project Settings (SupportedCultures) is set to fi-FI


Please reply me, this drive me crazy.
Posted
Comments
s.sheuly 22-Jun-10 6:18am
   
Thanks Abhinav s.
I did the same, set the UI thread manually.
System.Threading.Thread.CurrentThread.CurrentUICulture = new System.Globalization.CultureInfo("fi-FI");

But it didnt work.

Try changing the UI thread manually to point to the fi-FI culture.
If that works then you know that your settings are correct.
   
Did you get the chance to look into this issue. I did the same but it is not working. Please reply.
   

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
Top Experts
Last 24hrsThis month



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900