Click here to Skip to main content
14,644,700 members
Rate this:
Please Sign up or sign in to vote.
See more:
Hi,

I have made a desk top based application in C# visual studio 2008.
However, when I am going to debug mode it shows numeric variable value in hex(16 decimal) based, but I need actual 10 base decimal value not hex value.

How can I solve this problem.

Any help thanks in advance

Masud
Posted
Updated 7-Nov-10 22:24pm
v2
Comments
Dalek Dave 8-Nov-10 4:24am
   
Edited for Grammar, Syntax and Readability.
Rate this:
Please Sign up or sign in to vote.

Solution 1

Right click on the variable in Watch window and disable Hexadecimal Display. :)
   
Comments
Mahmudunnabi 13-Jul-10 4:54am
   
can u explain little bit detail please.I am bit confused when and where get watch
Mahmudunnabi 13-Jul-10 5:05am
   
thanks i got it
Nuri Ismail 13-Jul-10 5:07am
   
The debug tool windows (locals, autos, and watch) have a context menu that includes the "hexadecimal display" command. You can uncheck this command in order to see your variables in decimal. I believe that a picture is the best explanation, so check out this link:

http://blogs.msdn.com/b/saraford/archive/2008/02/13/did-you-know-you-can-view-numeric-values-in-hexadecimal-in-your-debug-windows-150.aspx

I hope this helps. :)

[EDIT] I should refresh my browser more often. You are welcome! :) [/EDIT]
hassan shehata 8-Nov-10 4:11am
   
thats true thanks so much for nuri ismail
Dalek Dave 8-Nov-10 4:25am
   
Good Call.
Rate this:
Please Sign up or sign in to vote.

Solution 2

goto watch window in the bottom of your page
mark over any variable then click right
pup tab will appear to you in it check disable Hexadecimal Display false

with my best whiches
   

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)




CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100