Click here to Skip to main content
15,884,237 members
Please Sign up or sign in to vote.
5.00/5 (1 vote)
I am trying to install Windows 10 IoT Core in Raspberry Pi. One of my college tell me that to do this your physical machine should also be installed with Windows 10 Insider Preview however i didn't find anywhere like this written in documentation. It was written at one place to not to install windows 10 on Virtual Machine as it will require to access SD card. So i am trying to follow these very simple steps as mentioned in Techcrunch | How To Install Windows 10 IoT On Your Raspberry Pi 2[^] from my Windows 8.1 64-Bit because the difference I found is just availability of dism.exe command.

I am trying these steps from powershell with "run as administrator" priority. but i stuck on step-5 of this article. I am getting Error: 87 and I am pasting powershell prompt that i am getting as below.
CSS
PS C:\iot> dism.exe /Apply-Image /ImageFile:flash.ffu /ApplyDrive:\\.\PhysicalDrive2 /SkipPlatformCheck

Deployment Image Servicing and Management tool
Version: 6.3.9600.17031


Error: 87

The /applydrive option is not recognized in this context.
For more information, refer to the help.

The DISM log file can be found at C:\Windows\Logs\DISM\dism.log

My SD card is detected on drive letter 2 as I found in list disk command under diskpart. you can find dism.log on This link[^].

Can anyone tell me how can i rectify this error.
Posted
Updated 8-May-15 20:59pm
v3

See https://ms-iot.github.io/content/Faqs.htm[^]:
Quote:
You need to use DISM on Windows 10 and not Windows 8.1.
 
Share this answer
 
Comments
Hitesh Rohilla 9-May-15 16:05pm    
Thanks for reply Jochen. I have successfully deployed Windows 10 on Raspberry Pi but i have to have Windows 10 installed on my physical machine. but i really wants to know what stops Windows 8.1 technically to do the so. I noticed Microsoft have habit to restrict people forcefully on so called "minimum requirements". They told minimum requirements for Windows Vista is 1GB RAM and restrict installation process. But once you cross the check point while installation you can change lower RAM later. My search is continue and i appreciate if you can share some info or hack to bypass this (if you know) otherwise i am okey to search alone :)
Jochen Arndt 10-May-15 4:23am    
The DSIM tool of Windows 8.1 did not know the ApplyDrive option (as the error message tells you). It has been added to the version shipped with Windows 10.
Hitesh Rohilla 2-Jul-15 3:00am    
But there must be some way to upgrade same utility in Windows 8/8.1 or previous. In any case even if you want test IoT Core you need to shift on Windows 10. Even before its stable version is not release yet. Microsoft provides way to install Other advance tools belongs to Visual studio 2015 in previous versions. Just because of this very tiny utility one have to shift on Windows 10. There is no way to do so in a virtual machine. Its more a problem then a solution.
Jochen Arndt 2-Jul-15 3:31am    
Microsoft decided to provide no update of the tool for Windows 8.1. Even if it would be updated (or you find a similar tool) you can't be sure that there are no other problems.

You should accept the situation.
this solution below worked for me (or see my blog post) :

get Windows 10 preview ISO,I used Windows10_InsiderPreview_x64_EN-US_10074.iso

mount Windows 10 ISO under Windows 8.1 (double click or right click/mount),
copy .\sources folder from ISO to local HDD, say
c:\temp\

copy flash.ffu from the Windows 10 IOT ZIP to
c:\temp\sources\
folder then open a command window using Admin permissions (hit Windows-X, then A)

find the disk # of your SD card using diskpart (you have used # 2 above)
type:
dism.exe /Apply-Image /ImageFile:flash.ffu /ApplyDrive:\\.\PhysicalDrive2 /SkipPlatformCheck


BTW my first time at this failed however my 2nd attempt worked. Unsure if any bearing on it, but first time I'd formatted SD card using FAT32, second time using NTFS. Although I'll still be doing a dual boot VHD install to test Windows 10 when I have some free time, this worked for me and saved me a good bit of time.
 
Share this answer
 
Comments
Hitesh Rohilla 2-Jul-15 2:55am    
That is already considered. My question revolves around availability of same utility in Windows 8.1 or previous. For windows 10 its already there.

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
Top Experts
Last 24hrsThis month


CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900