Click here to Skip to main content
15,795,512 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more: , +
I have recently finished building a Multi-Tier database Application using the datasnap technology in Delphi. I have built the datasnap Client app in Delphi-Object Pascal, and linked it to a datasnap server app that communicates with SQL Server 2012. When I run my Client app on the Windows desktop(64bit), it works just fine; it connects to the datasnap server, and can reads and update the database. However, when i run it on an Android Device (Samsung galaxy 4.2.2),while the server is running, it deploys successfully and opens, but whenever i try to use any functions such as clicking a button, it freezes and then sends me the error:

Socket Error #110 Connection timed out.

I have a checkbox function with a statement that opens the connection to the server once checked. When I attempt to check this box, it gives me the same error above.

How can i run the app on a mobile device, and have it communicate with the datasnap server successfully?

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900