Click here to Skip to main content
13,050,450 members (131,181 online)
Click here to Skip to main content
Add your own
alternative version

Tagged as

Stats

8.6K views
2 bookmarked
Posted 29 Jan 2013

Embedded YouTube videos z-index problem while playing

, 29 Jan 2013
Rate this:
Please Sign up or sign in to vote.
Embedded YouTube videos z-index problem while playing.

Problem Description 

If you come across embedding YouTube videos to your website, you might know this problem. When some elements in your page have a higher z-index to float on other elements, the YouTube embedded video ignores their z-index and hides them under it. 

Tip 

A simple way to solve this is to add the wmode=transparent property to the source URL of the video: 

<iframe width="752" height="425" src="http://www.youtube.com/embed/O2R-ixfQtwE?wmode=transparent&rel=0&modestbranding=1" 

  frameborder="0" allowfullscreen=""></iframe>

License

This article, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

Share

About the Author

Veera Prathap Annem
Software Developer
India India
This member doesn't quite have enough reputation to be able to display their biography and homepage.

You may also be interested in...

Pro

Comments and Discussions

 
-- There are no messages in this forum --
Permalink | Advertise | Privacy | Terms of Use | Mobile
Web02 | 2.8.170713.1 | Last Updated 29 Jan 2013
Article Copyright 2013 by Veera Prathap Annem
Everything else Copyright © CodeProject, 1999-2017
Layout: fixed | fluid