Click here to Skip to main content
12,630,137 members (27,077 online)
Rate this:
 
Please Sign up or sign in to vote.
See more: C# installer
Hello Everyone,
Please guide me to this error I received whenever I run the application made using C#, the catch is, it is working in other computers but returns an error in one computer:
This is the error:
System.BadImageFormatException: Could not load file or assembly 'System.EnterpriseServices, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The module was expected to contain an assembly manifest.
Thank you very much!
Posted 11-Jul-11 5:05am
Updated 11-Jul-11 5:28am
wizardzz105.4K
v2
Comments
SAKryukov 11-Jul-11 16:04pm
   
Not enough information.
--SA
Syed Salman Raza Zaidi 12-Jul-11 3:34am
   
might be because of Framework version is different
musefan 12-Jul-11 4:15am
   
Does your application crash straight away? or after some time? What does your application do? I have seen BadImageFormatException for memory leaks too, specifically when doing custom drawing (OnPaint event etc.) and not disposing images when using them in a PictureBox (or similar)

1 solution

Rate this: bad
 
good
Please Sign up or sign in to vote.

Solution 1

Have you included any dll in your application which is protected against deployment with the public key RSA encryption?
I think that some thing like than may cause this error.
  Permalink  

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
Top Experts
Last 24hrsThis month


Advertise | Privacy | Mobile
Web02 | 2.8.161205.3 | Last Updated 18 Jul 2011
Copyright © CodeProject, 1999-2016
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100