Click here to Skip to main content
12,624,887 members (35,137 online)
Rate this:
 
Please Sign up or sign in to vote.
See more: C# ASP.NET
Hi,

in my sample project the AutoCompleteExtender takes about 12 to 15 seconds to load, but only the 1st time.After the first time it takes 0.5-1 sec.

How can i solve this. If any one about this tell me.

Regards
Nanda Kishore.CH
Posted 11-Oct-12 22:29pm
Comments
Aman.A 12-Oct-12 4:01am
   
You are the same person asking about the "Page level cache" problem too, aren't you? :) Anyway, in this case it really depends on how much data you are loading in your auto-complete extender and whether or not the data is coming from just one table or its being joined with several other tables and then returned. And the reason it takes only 0.5-1 secs second time on, is that it caches previously loaded results and uses them if you type in the same query string again (i.e. if you set the caching property to true). Have a look at your DB queries and the query execution plan. Optimisation problems are very specific to the system architecture and overall design, so it is difficult to come up with a general remedy.

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
Top Experts
Last 24hrsThis month


Advertise | Privacy | Mobile
Web02 | 2.8.161128.1 | Last Updated 12 Oct 2012
Copyright © CodeProject, 1999-2016
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100