Can I suggest a couple of changes, before you go any further?
Firstly, don't use the Visual Studio default names for anything! When you have an application full of button1, button2, button3, textBox1, textBox2, etc., it is very difficult to work out what is going on. If you use descriptive names instead, then your code is both easier to read, and (generally) more reliable, because you don't use the textbox containing the city name as a departure date! :laugh:
Secondly, Setting up your city - city distances via separate arrays is a bit of a pain for you to work with - it is dfifficult to automate via loops if you =have they all as separate arrays. Consider changing to a two dimensional array, with indexes for cities:
0 1 2
0 0 100 150
1 100 0 50
2 150 50 0
Then when you are looking for distances, it's just cityDistance[city1, city2] rather than having to work out which array to use for city1, then offset into it for city2.
When you have thought about that for a while, you should find it relatively simple to complete your homework! :D