Click here to Skip to main content
12,629,107 members (35,427 online)
Rate this:
 
Please Sign up or sign in to vote.
See more: ASP.NET Ajax
Hi All.

I am a newbie in ajax and trying to use ajax hovermenuextender control. I have downloaded the demo projects of hovermenuextender from codeproject.com as well as from other websites and they all work fine.

Even when I try to create my own aspx page in those downloaded projects, and implement hovermenuextender, it works fine. But when i create a new simple asp.net project, and try to implement this functionality, it doesn't work.

I have added reference of ajaxtoolkit 3.5 and also used the "display:none" for popup panel to hide it at beginning. But I hover the linkbutton, it doesnt show the popup panel.

My aspx code is as follows:

<%@ Page Language="C#" AutoEventWireup="true"  CodeFile="Default.aspx.cs" Inherits="_Default" %>
 
<%@ Register Assembly="AjaxControlToolkit" Namespace="AjaxControlToolkit" TagPrefix="asp" %>
 
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
 
<html xmlns="http://www.w3.org/1999/xhtml">
<head id="Head1" runat="server">
    <title>Untitled Page</title>
</head>
<body>
    <form id="form1" runat="server">
    <asp:ScriptManager ID="ScriptManager1" runat="server">
    </asp:ScriptManager>
      <asp:LinkButton ID="LinkButton1" runat="server">LinkButton</asp:LinkButton>
    <asp:Panel ID="Panel1" runat="server" CssClass="pop">
        <table><tr><td>hellow avinash</td></tr></table>
    </asp:Panel>
    <asp:HoverMenuExtender ID="HoverMenuExtender1" runat="server" PopupControlID="Panel1" TargetControlID="LinkButton1" PopupPosition="right" OffsetX="-100"
            OffsetY="-6"
            PopDelay="500">
    </asp:HoverMenuExtender>
     </form>
</body>
</html>

Please let me know where the problem is and how to solve it.
Posted 19-Feb-13 7:25am

1 solution

Rate this: bad
 
good
Please Sign up or sign in to vote.

Solution 2

Hello friends,

I have found the problem and solution too.
The problem was that I was using re-used dll file "AjaxControlToolkit.dll". It means I was
clicking in the menu Website->Add a reference

Then I was selecting the AjaxControlToolkit.dll file from the Bin folder of downloaded projects. And thus, it was not working in my website.

Solution:
I downloaded new AjaxControlToolkit.dll(only controls as recommended by the providers) for framework 3.5 from here and used it as normally we do and it worked.
  Permalink  

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
Top Experts
Last 24hrsThis month


Advertise | Privacy | Mobile
Web02 | 2.8.161205.3 | Last Updated 19 Feb 2013
Copyright © CodeProject, 1999-2016
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100