Click here to Skip to main content
14,299,406 members

SharePoint

 
SuggestionRe: Generating site map in SharePoint Online Pin
Richard MacCutchan10-Aug-15 21:58
protectorRichard MacCutchan10-Aug-15 21:58 
AnswerMessage Closed Pin
28-Oct-15 0:22
memberMember 1209387328-Oct-15 0:22 
QuestionProgrammatically delete users from all site collections Pin
Member 308518516-Jul-15 3:52
memberMember 308518516-Jul-15 3:52 
AnswerRe: Programmatically delete users from all site collections Pin
Rsharepoint25-Nov-15 15:25
memberRsharepoint25-Nov-15 15:25 
QuestionHow to Apply Master page programmatically for a wiki page created programmatically Pin
Balajinarni14-Jun-15 20:00
memberBalajinarni14-Jun-15 20:00 
QuestionSearch is giving intermittent results in Sharepoint 2010 production environment. Pin
Member 1083323324-Apr-15 1:21
memberMember 1083323324-Apr-15 1:21 
AnswerMessage Closed Pin
28-Oct-15 0:24
memberMember 1209387328-Oct-15 0:24 
QuestionSharePoint 2013 Workflow Suspends Pin
Sakti Mohapatra23-Apr-15 2:15
memberSakti Mohapatra23-Apr-15 2:15 
Hi All,
I am facing an issue with SP2013 Custom Workflow developed using Visual Studio 2012.
Objective of the Custom workflow: User fills the form and submit, list get updated and workflow will initiate and go for the process.
Issue: After the deployment of WF, for first time when user is filling the form and submit, list is getting updated. But the Workflow Goes to "Suspend" mode. (This Custom Workflow has a configuration file where we are providing other details including ID of Impersonator (farm is running under Claim Based Authentication).

Work flow works fine once when the Impersonator initiate the workflow (Fill the form and submit for approval) and everything works fine after that.

Following steps are already performed

1.Make sure User profile synchronization is started.
2.Make sure the user is not the SharePoint system user.
3.Make sure the user by whom you are logged is available in User Profile list.
4.Step full synchronization of User Profile Application.

From the ULS logs it seems the user's security token from the STS service and User profile service is not being issued.
Appreciate any thoughts or solution.

Following are the log files.

<-------------------------------Information taken from "http://YYYY.XXXXX.com/sites/xxxx/_layouts/15/wrkstat.aspx" where it is showing workflow status as "Suspend"------->

http://yyyy.XXXX.com/sites/xxxx/_vti_bin/client.svc/sp.utilities.utility.ResolvePrincipalInCurrentcontext(input=@ParamUser,scopes='15',sources='15',inputIsEmailOnly='false',addToUserInfoList='False')?%40ParamUser='i%3A0%23.w%7CXXXXX%5Csps_biscomdev' Correlation Id: f5bd8793-a53c-2127-bfb1-70bc172425e8 Instance Id: 14a985a0-60c8-42db-a42c-c752190b8106

RequestorId: f5bd8793-a53c-2127-0000-000000000000. Details: RequestorId: f5bd8793-a53c-2127-0000-000000000000. Details: An unhandled exception occurred during the execution of the workflow instance. Exception details: System.ApplicationException: HTTP 401 {"error_description":"The server was unable to process the request due to an internal error. For more information about the error, either turn on IncludeExceptionDetailInFaults (either from ServiceBehaviorAttribute or from the <servicedebug> configuration behavior) on the server in order to send the exception information back to the client, or turn on tracing as per the Microsoft .NET Framework SDK documentation and inspect the server trace logs."} {"x-ms-diagnostics":["3001000;reason=\"There has been an error authenticating the request.\";category=\"invalid_client\""],"SPRequestGuid":["f5bd8793-a53c-2127-8654-672758a68234"],"request-id":["f5bd8793-a53c-2127-8654-672758a68234"],"X-FRAME-OPTIONS":["SAMEORIGIN"],"SPRequestDuration":["34"],"SPIisLatency":["0"],"Server":["Microsoft-IIS\/7.5"],"WWW-Authenticate":["Bearer realm=\"b14e1e0f-257f-42ec-a92d-377479e0ec8d\",client_id=\"00000003-0000-0ff1-ce00-000000000000\",trusted_issuers=\"00000005-0000-0000-c000-000000000000@*,00000003-0000-0ff1-ce00-000000000000@b14e1e0f-257f-42ec-a92d-377479e0ec8d\"","NTLM"],"X-Powered-By":["ASP.NET"],"MicrosoftSharePointTeamServices":["15.0.0.4420"],"X-Content-Type-Options":["nosniff"],"X-MS-InvokeApp":["1; RequireReadOnly"],"Date":["Fri, 10 Apr 2015 19:48:07 GMT"]} at Microsoft.Activities.Hosting.Runtime.Subroutine.SubroutineChild.Execute(CodeActivityContext context) at System.Activities.CodeActivity.InternalExecute(ActivityInstance instance, ActivityExecutor executor, BookmarkManager bookmarkManager) at System.Activities.Runtime.ActivityExecutor.ExecuteActivityWorkItem.ExecuteBody(ActivityExecutor executor, BookmarkManager bookmarkManager, Location resultLocation)

<-----ULS Log--------------------------------------------------------->

04/16/2015 15:49:10.51 OWSTIMER.EXE (0x3B3C) 0x39A4 SharePoint Server Search Administration aij4q Medium SystemMetricsTraceAggregator error getting next value System.ComponentModel.Win32Exception (0x80004005): Unknown error (0xc0000bc6) at Microsoft.Office.Server.Search.Performance.Pdh.CheckReturnValue(PDH_STATUS status, Boolean throwOnError) at Microsoft.Office.Server.Search.Performance.PerformanceCounter.NextValue(Int32 retry, Int32 retryInterval, Boolean initialize) at Microsoft.Office.Server.Search.Monitoring.SystemMetricsTraceAggregator.Flush(ILoggingProvider persist) 3f5ffd9c-1ea7-d0c8-efd5-08730af690a1
04/16/2015 15:49:10.95 w3wp.exe (0x1C74) 0x20CC SharePoint Server Workflow Services aj526 Medium WorkflowMessagingClient is using MSMQ 3f5ffd9c-fec7-d0c8-efd5-089b983d7c28
04/16/2015 15:49:14.11 w3wp.exe (0x1C74) 0x1E74 SharePoint Portal Server User Profiles aj2aw High [Forced due to logging gap, Original Level: Verbose] GetPartitionPropertiesCache :: ApplicationId = {0} 405ffd9c-ae9d-d0c8-efd5-045b09583aac
04/16/2015 15:49:15.43 w3wp.exe (0x0C48) 0x2AA4 SharePoint Portal Server User Profiles ae0s1 High Identity claims mapped to '0' user profiles. Claims: [nameid: '', nii: 'windows', upn: '', smtp: '', sip: ''], User Profiles: f5bd8793-a53c-2127-a845-3695a6bf9678
04/16/2015 15:49:15.45 w3wp.exe (0x0C48) 0x2AA4 SharePoint Portal Server User Profiles ae0sr Unexpected UserProfileException caught.. Exception Microsoft.Office.Server.Security.UserProfileNoUserFoundException: 3001002;reason=The incoming identity is not mapped to any user profile account in SharePoint. Possible cause is that no user profiles are created in user profile database. Contact your administrator. at Microsoft.Office.Server.Security.UserProfileIdentityClaimMapper.GetSingleUserProfileFromClaimsList(UserProfileManager upManager, IEnumerable`1 identityClaims) at Microsoft.Office.Server.Security.UserProfileIdentityClaimMapper.<>c__DisplayClass2.<getmappedidentityclaim>b__0() is thrown. f5bd8793-a53c-2127-a845-3695a6bf9678
04/16/2015 15:49:15.45 w3wp.exe (0x0C48) 0x2AA4 SharePoint Portal Server User Profiles ae0su High The set of claims could not be mapped to a single user identity. Exception 3001002;reason=The incoming identity is not mapped to any user profile account in SharePoint. Possible cause is that no user profiles are created in user profile database. Contact your administrator. has occured. f5bd8793-a53c-2127-a845-3695a6bf9678
04/16/2015 15:49:15.46 w3wp.exe (0x1C74) 0x1E74 SharePoint Server Search Query dn4s High FetchDataFromURL start at(outside if): 1 param: start 405ffd9c-ae9d-d0c8-efd5-045b09583aac
04/16/2015 15:49:15.56 w3wp.exe (0x0C48) 0x0518 SharePoint Portal Server User Profiles ae0s1 High Identity claims mapped to '0' user profiles. Claims: [nameid: '', nii: 'windows', upn: '', smtp: '', sip: ''], User Profiles: f5bd8793-a53c-2127-94b8-bfec2dd819f1
04/16/2015 15:49:15.56 w3wp.exe (0x0C48) 0x0518 SharePoint Portal Server User Profiles ae0sr Unexpected UserProfileException caught.. Exception Microsoft.Office.Server.Security.UserProfileNoUserFoundException: 3001002;reason=The incoming identity is not mapped to any user profile account in SharePoint. Possible cause is that no user profiles are created in user profile database. Contact your administrator. at Microsoft.Office.Server.Security.UserProfileIdentityClaimMapper.GetSingleUserProfileFromClaimsList(UserProfileManager upManager, IEnumerable`1 identityClaims) at Microsoft.Office.Server.Security.UserProfileIdentityClaimMapper.<>c__DisplayClass2.<getmappedidentityclaim>b__0() is thrown. f5bd8793-a53c-2127-94b8-bfec2dd819f1
04/16/2015 15:49:15.56 w3wp.exe (0x0C48) 0x0518 SharePoint Portal Server User Profiles ae0su High The set of claims could not be mapped to a single user identity. Exception 3001002;reason=The incoming identity is not mapped to any user profile account in SharePoint. Possible cause is that no user profiles are created in user profile database. Contact your administrator. has occured. f5bd8793-a53c-2127-94b8-bfec2dd819f1
04/16/2015 15:49:17.68 w3wp.exe (0x1C74) 0x1AB8 SharePoint Server Search Query dn4s High FetchDataFromURL start at(outside if): 1 param: start 415ffd9c-fe81-d0c8-efd5-069f50839f81
04/16/2015 15:49:18.05 w3wp.exe (0x1C74) 0x2554 SharePoint Server Search Query dn4s High FetchDataFromURL start at(outside if): 1 param: start 415ffd9c-7e98-d0c8-efd5-036cbbbe1377
04/16/2015 15:49:19.99 w3wp.exe (0x1C74) 0x3BBC SharePoint Server Search Query dn4s High FetchDataFromURL start at(outside if): 1 param: start 425ffd9c-8e0d-d0c8-efd5-0dc40744b558
------------------
Regards
Sakti
Answer[REPOST] Pin
Sascha Lefèvre23-Apr-15 2:36
professionalSascha Lefèvre23-Apr-15 2:36 
QuestionError occurred in deployment step 'Activate Features': Pin
Mohd Tahir23-Apr-15 1:33
professionalMohd Tahir23-Apr-15 1:33 
AnswerRe: Error occurred in deployment step 'Activate Features': Pin
Sascha Lefèvre23-Apr-15 2:25
professionalSascha Lefèvre23-Apr-15 2:25 
AnswerRe: Error occurred in deployment step 'Activate Features': Pin
lakshmi prasad sirigiri6-Jul-15 19:54
memberlakshmi prasad sirigiri6-Jul-15 19:54 
AnswerRe: Error occurred in deployment step 'Activate Features': Pin
Member 1048483424-Aug-15 23:44
professionalMember 1048483424-Aug-15 23:44 
GeneralPeople picker not able to resolve users stored in sdf file on identity server Pin
Manish Chauhan6-Apr-15 23:58
memberManish Chauhan6-Apr-15 23:58 
QuestionIs it possible to have drill down in graphs and combinational graphs in Sharepoint 2013 using dashboard designer. Pin
Member 115864066-Apr-15 22:14
memberMember 115864066-Apr-15 22:14 
AnswerRe: Is it possible to have drill down in graphs and combinational graphs in Sharepoint 2013 using dashboard designer. Pin
nrramesh16-Apr-15 12:04
membernrramesh16-Apr-15 12:04 
AnswerRe: Is it possible to have drill down in graphs and combinational graphs in Sharepoint 2013 using dashboard designer. Pin
lakshmi prasad sirigiri6-Jul-15 19:48
memberlakshmi prasad sirigiri6-Jul-15 19:48 
QuestionSharePoint Pin
Member 1156887930-Mar-15 21:05
memberMember 1156887930-Mar-15 21:05 
AnswerRe: SharePoint Pin
Nibin228-Jun-15 21:41
memberNibin228-Jun-15 21:41 
AnswerMessage Closed Pin
28-Oct-15 0:24
memberMember 1209387328-Oct-15 0:24 
QuestionHow can I change image on hover? Pin
Danpeking23-Mar-15 23:32
memberDanpeking23-Mar-15 23:32 
AnswerRe: How can I change image on hover? Pin
Hitesh Sharma _13-May-15 4:42
memberHitesh Sharma _13-May-15 4:42 
AnswerRe: How can I change image on hover? Pin
AbuNav30-Jun-15 0:01
professionalAbuNav30-Jun-15 0:01 
QuestionSharePoint 2013 Pin
Member 1080649723-Mar-15 2:55
memberMember 1080649723-Mar-15 2:55 
AnswerRe: SharePoint 2013 Pin
ZurdoDev23-Mar-15 3:57
professionalZurdoDev23-Mar-15 3:57 

General General    News News    Suggestion Suggestion    Question Question    Bug Bug    Answer Answer    Joke Joke    Praise Praise    Rant Rant    Admin Admin   

Use Ctrl+Left/Right to switch messages, Ctrl+Up/Down to switch threads, Ctrl+Shift+Left/Right to switch pages.