Click here to Skip to main content
Click here to Skip to main content

Debugger showing wrong source file when debugging in VS2005

, 24 Jun 2011
Rate this:
Please Sign up or sign in to vote.
Debugger showing wrong source file when debugging in VS2005
I had this problem when debugging that it shows wrong source file. When I went to disassembler, I found that it is showing wrong path (not the path which I was trying to debug).
 
Note: I have the same project in 2 different locations. When debugging, the file is pointed to different location.
 
I tried deleting and updating the DLL. But that did not work.
 
Finally I figured out the reason and am posting here so that it may help any other developer facing the same issue. I did the below steps!!
  1. Right click solution from solution explorer.
  2. Go to properties of the open solution.
  3. Click on debug source files. Under this, you will find a window "Do not look for these source files".
  4. Under that, the path of my source files was listed.
  5. I deleted the wrong source file path, it worked out. (I don't know yet how the path got updated there, but finally it worked after deleting from that location.)
Naina

License

This article, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

About the Author

nainakarri

India India
Developer

Comments and Discussions

 
GeneralReason for my vote of 4 Hopefully some one will get benefit ... Pinmemberjawed.ace22-Jun-11 1:24 

General General    News News    Suggestion Suggestion    Question Question    Bug Bug    Answer Answer    Joke Joke    Rant Rant    Admin Admin   

Use Ctrl+Left/Right to switch messages, Ctrl+Up/Down to switch threads, Ctrl+Shift+Left/Right to switch pages.

| Advertise | Privacy | Mobile
Web04 | 2.8.140718.1 | Last Updated 24 Jun 2011
Article Copyright 2011 by nainakarri
Everything else Copyright © CodeProject, 1999-2014
Terms of Service
Layout: fixed | fluid