Click here to Skip to main content
15,919,613 members
Please Sign up or sign in to vote.
4.00/5 (1 vote)
See more:
Hello All,

I have WCF Service (Hosted in Windows service ) and trying connect from other system
I am getting below error
The open operation did not complete within the allotted timeout of 00:01:00. The time allotted to this operation may have been a portion of a longer timeout.

I have tried several ways as
1]Made Fire wall off in both server and client
2]Security None
3]For some reason I have to use WsDualHttpBinding
4]Using same network (not over internet)

But In same machine It works !

My client config
        <binding name="ConfigService" closeTimeout="00:01:00"
            openTimeout="00:01:00" receiveTimeout="00:15:00" sendTimeout="00:01:00"
            bypassProxyOnLocal="false" transactionFlow="false" hostNameComparisonMode="StrongWildcard"
            maxBufferPoolSize="2147483647" maxReceivedMessageSize="2147483647"
            messageEncoding="Text" textEncoding="utf-8" useDefaultWebProxy="true">
          <readerQuotas maxDepth="2147483647" maxStringContentLength="2147483647" maxArrayLength="2147483647"
              maxBytesPerRead="2147483647" maxNameTableCharCount="2147483647" />
          <reliableSession ordered="true" inactivityTimeout="00:10:00" />
      <security mode="None">
        <message clientCredentialType="None" negotiateServiceCredential="false" />
      <endpoint address="http://Ip-address:8725/ConfigService/Service"
          binding="wsDualHttpBinding" bindingConfiguration="ConfigService"
          contract="IConfigServiceLib" name="MyService">


      <messageLogging logEntireMessage="true" logMalformedMessages="true"
        logMessagesAtServiceLevel="true" logMessagesAtTransportLevel="true" />
        <behavior name="WsDualHttpBinding">
          <serviceMetadata httpGetEnabled="true" httpsGetEnabled="false"/>
          <serviceDebug includeExceptionDetailInFaults="true" />
    <bindings >
        <binding name="higherMessageSize_WS" closeTimeout="10:01:00" clientBaseAddress="http://Localhost:8723/ConfigUI"
        openTimeout="10:01:00" receiveTimeout="10:10:00" sendTimeout="10:01:00"
        bypassProxyOnLocal="false" transactionFlow="false" hostNameComparisonMode="StrongWildcard"
        maxBufferPoolSize="5242880000" maxReceivedMessageSize="655360000" messageEncoding="Text" 
        textEncoding="utf-8" useDefaultWebProxy="true">
		<security mode="None">
        <message clientCredentialType="None" negotiateServiceCredential="false" />
      <service behaviorConfiguration="WsDualHttpBinding" name="ServiceCon">
        <clear />
        <endpoint address="ConfiguratorService"
          binding="wsDualHttpBinding" bindingConfiguration="higherMessageSize_WS" name="MyService"
          contract="IContract" />
        <endpoint binding="mexHttpBinding" bindingConfiguration="" name="mex"
          contract="IMetadataExchange" />
            <add baseAddress="http://localhost:8725/ConfigService" />

Please help Me
Updated 11-Mar-13 3:24am

open your browser and try navigate this URL:

maybe your problem is on the binding configuration and post your result here please
Share this answer
CrystalB 12-Mar-13 6:55am    
Hey Thank you very much. your solutions strikes me... Now it is solved :)
Two Problems
1)As you said My URL Was not proper (It was not reading from config :()
2)Some security problem..
But Now every thing OK
jdvaghasiya 9-Jun-15 13:02pm    
hello CrystalB can you do me favor,
please paste your web.config (server) data over here. i am facing the same issue from almost a month. i read the above answer but i didnt get actually how you resolved this issue
_pohenix_ 12-Mar-13 8:33am    
well, I'm glad I was of help
Maybe you should look at this[^].

Happy coding.
Share this answer

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900