Click here to Skip to main content
15,883,606 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
While working on a project, I am trying to connect to MS Access DB using in Visual Studion IDE but whenever I run the program, the chrome browser displays that 'Microsoft.ACE.OLEDB.16.0' is not registered.

I've been through many sites to resolve the issue but it has not been solved yet.

I am working on Office 2016, windows 10 (64 bit).

What I have tried:

I have downloaded the comp-ability and distribution platforms from the Microsoft websites but the issue doesn't seem to be solved still.
Posted
Updated 27-Feb-17 9:46am

A couple of things...

First, Which version of Office 2016 do you have installed? If it's the 32-bit version of Office, your application has to be compiled for a Platform Target of x86, NOT AnyCPU. Go into your Project Properties and click on the Build tab, you'll find it in there.

If you've got Office 2016 Click-To-Run installed, you have to install a separate Access runtime. Like above, you can either install the 2010 version or the 2013 version. It really doesn't matter. (If you try to install the 2016 version it'll tell you that you can't install it because you already have 2016 Click-To-Run installed.)

Once you have that install you have to change your connection string to use the correct version of the ACE engine. For the Access Runtime 2013, it's 'Microsoft.ACE.OLEDB.15.0'. For Office 2010, it's 'Microsoft.ACE.OLEDB.14.0'.
 
Share this answer
 
 
Share this answer
 

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS


CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900