Click here to Skip to main content
Rate this: bad
good
Please Sign up or sign in to vote.
See more: .NET3.5 C#4.0
i have an application and installed on IIS server...
 
but when i want to print report from this application on the other machine...
the report shows well but toolbar button images not shown and also not working...
and a new window appear with the URL as:
 
"http://ipaddress/aspnet_client/System_Web/2_0_50727/CrystalReportWebFormViewer4/html/crystalexportdialog.htm"
 
and "Page can not be found" error showed...
 
please help me....
thanks in adv
Posted 26-Sep-11 23:04pm
bkthebest1.5K
Edited 27-Sep-11 20:38pm
v2
Comments
pk@koroor at 27-Sep-11 6:30am
   
this is the common problem for crystal reports , have look at :http://stackoverflow.com/questions/727825/crystal-reports-images-not-visible-in-web-viewer
 
http://forums.asp.net/t/1571760.aspx/1
bkthebest at 27-Sep-11 7:17am
   
hi pk@koroor,

i still have problem...
i m using code

ReportDocument rd = new ReportDocument();
rd.PrintToPrinter(1, false, 0, 0);

it prints the document but only work with local system...
but when i deployed application on iis server...
it stopped working
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 2

solved...
i solved my prob my self...
 
i have a solution...that fix up my problem
 
make a folder named "aspnet_client" anywhere on your HD
now
make another folder in that folder named "System_Web" again make a new folder in that("System_Web") named "2_0_50727"
now
open this path
 
C:\Windows\Microsoft.NET\Framework\v2.0.50727\ASP.NETClientFiles
 
now copy the folder named:CrystalReportWebFormViewer4
and paste it in your folder hierarchy as
 
yourdrive/aspnet_client/System_Web/2_0_50727
now
 
Open IIS, select your website, right click and select create new
 
virtual directory. Named aspnet_client and give its path to your folder hierarchy...
 
now your website have a virtual directory named aspnet_client...
 
problem solved...
  Permalink  
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 5

For I.E. IN Windows 7 do following settings
Copy folder name as "CrystalReportWebFormViewer3" from
C:\Windows\Microsoft.NET\Framework\v2.0.50727\ASP.NETClientFiles
and past into following location
C:\inetpub\wwwroot\aspnet_client\system_web\2_0_50727\
 
For Mozilla Firefox windows 7 Add following code in your Web.config file
 
<appSettings>
<add key="aspnet:UseLegacyBrowserCaps" value="true" />
</appSettings>
  Permalink  
Comments
AlwaysHC at 17-Oct-14 11:18am
   
Thank you so much for your solution!
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 3

For I.E. IN Windows 7 do following settings
Copy folder name as "CrystalReportWebFormViewer3" from
C:\Windows\Microsoft.NET\Framework\v2.0.50727\ASP.NETClientFiles
and past into following location
C:\inetpub\wwwroot\aspnet_client\system_web\2_0_50727\
  Permalink  

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
0 Maciej Los 495
1 Sergey Alexandrovich Kryukov 479
2 OriginalGriff 360
3 CHill60 280
4 CPallini 250
0 Sergey Alexandrovich Kryukov 10,102
1 OriginalGriff 9,495
2 Peter Leow 5,241
3 Kornfeld Eliyahu Peter 3,373
4 Maciej Los 3,076


Advertise | Privacy | Mobile
Web04 | 2.8.150327.1 | Last Updated 5 Sep 2014
Copyright © CodeProject, 1999-2015
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100