Click here to Skip to main content
12,397,773 members (57,632 online)
Rate this:
 
Please Sign up or sign in to vote.
See more: WinXP VS.NET2003 C++ Windows , +
I've been looking around for some clues to fix the following behavior I'm having using an MFC application, developed with VS.NET2003 and OpenGL, on Win7. I'm getting flickering of main view when resizing (fixed!), and traces on rubber-band boxes and polyline drawing (images available here). These artifacts do not occur on XP. I'm testing on a new laptop with Win7 Pro and I've updated the graphics drivers but the problem persists.

The application does attempt to implement double buffering using OpenGL (albeit not proven to be correct). I've ported the solution to VS2010 on the Win7 laptop, compiled it and still get the same behavior.

I'm an engineer pretending to be a graphics programmer and I'm looking for directions for debugging this problem and I'm open to any suggestions.

I received one suggestion regarding Aero - I turned that off and it did eliminate the flickering on re-size (Thanks for that suggestion Smile | :) ). Unfortunately, the tracing problem with rubber-banding persists.

Ted
Posted 2-Jan-12 7:31am
tlillys249
Updated 3-Jan-12 8:01am
v4
Comments
Code-o-mat 3-Jan-12 7:02am
   
Does it happen if you turn off "Aero" in Win7?

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
Top Experts
Last 24hrsThis month


Advertise | Privacy | Mobile
Web02 | 2.8.160721.1 | Last Updated 3 Jan 2012
Copyright © CodeProject, 1999-2016
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100