Click here to Skip to main content
Rate this: bad
good
Please Sign up or sign in to vote.
See more: Android Eclipse
Hello
 
I have a laptop windows 64bit with Java 1.7, Android Eclipse Classic 4.2 + installed + sdk for Windows.
 
Now I want to run my program and I always get "failed to install - apk on device 'emulator-5554! , Launch canceled!

Any help.
Posted 6-Aug-12 10:36am
webfree215
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 1

Try launching the emulator separately (pretty sure you can, I don't know how off the top of my head, I use my phone for testing) and removing your program manually, then relaunch it. Or make another virtual device and try it on that one.
  Permalink  
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 2

Thank you but how do I launch the emulator separately. And how to I make another virtual device. would really like to solve this.
  Permalink  
Comments
Sandeep Mewara at 7-Aug-12 11:26am
   
This is not an answer. Please use 'Have a Question or Comment' link to respond to an answer. It will notify answerer of your comment such that he can come back and reply. Or if needed, use Improve Question link to edit/update your question at anytime.
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 3

open avd manager and click on emulator which you want to start separately
and click on start
  Permalink  
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 4

I tried to do that but I only have 1 emulator thus why I couldnt click on start, for it had been already started.
  Permalink  
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 5

In a command window try typing
adb devices
to verify your device is actually connected to the server.
Try restarting the adb server process
adb kill-server
followed by
adb start-server
 
The adb command is found in <sdk>/platform-tools/
  Permalink  
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 6

Thank you Niklas will try that - though when I tried to open the avd.exe it just showed a quick .dos side and afterwards nothing happened. Will have to check this one if it functions at all.
  Permalink  

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



Advertise | Privacy | Mobile
Web02 | 2.8.140821.2 | Last Updated 8 Aug 2012
Copyright © CodeProject, 1999-2014
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100