Click here to Skip to main content
15,890,897 members
Please Sign up or sign in to vote.
1.00/5 (1 vote)
See more:
the code below outputs:
Sample Input
10 4 | -
where;
10 is the number of interval
4 is the width of an interval
/ is the major mark
* is the minor mark
Sample Output
|----|----|----|----|----|----|----|----|----|----|

I want to add another loop that when you type 'n' as the major mark
the output would be:
Sample Input
3 2 n x
Sample Output
0xx1xx2xx3

'n' value are numbers from 0, 1, 2, 3... and so on.

What I have tried:

C++
#include <iostream>
using namespace std;
int main()
{
    int a, b;
    char c, d;
    cin >> a >> b >> c >> d;

    for (int row = 1; row <= a; row++ ){
        cout << c;
        for (int cols = 1; cols <= b; cols++){
            cout << d;
        }
    }
    cout << c;
}
Posted
Updated 22-Sep-21 22:19pm
v3
Comments
Richard MacCutchan 23-Sep-21 6:58am    
Just check if c is a number when it is input. If so use its values rather than the single character.

While we are more than willing to help those that are stuck, that doesn't mean that we are here to do it all for you! We can't do all the work, you are either getting paid for this, or it's part of your grades and it wouldn't be at all fair for us to do it all for you.

So we need you to do the work, and we will help you when you get stuck. That doesn't mean we will give you a step by step solution you can hand in!
Start by explaining where you are at the moment, and what the next step in the process is. Then tell us what you have tried to get that next step working, and what happened when you did.

If you are having problems getting started at all, then this may help: How to Write Code to Solve a Problem, A Beginner's Guide[^]
 
Share this answer
 
Best is to use the debugger when the code doesnt work as expected. Find some debugger tutorial to kickstart and get some insights.

In C loops are from 0 to less the end. That would change your code like this:
C++
for (int row = 0; row < a; row++ ){
        cout << c;
        for (int cols = 0; cols < b; cols++){
            cout << d;
        }
    }
I would use better names for the vars and chars like for loops
 
Share this answer
 

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900