Click here to Skip to main content
Rate this: bad
good
Please Sign up or sign in to vote.
See more: CrystalReports
hi all,
 
Reports do not render properly in IE 10 using ASP.NET Crystal Reports Viewer. All I see is vertical bars. If I switch to IE 9 mode in Developer tools, report looks fine.kindly share to us if u know abt this
 

Thanks
Posted 16-Apr-13 4:09am
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 3

After the first :
 
CrystalReportViewer1.ReportSource
Add :
 System.Web.HttpBrowserCapabilities vBrowser = Request.Browser;
        if (vBrowser.Type == "IE10" && vBrowser.MajorVersion > 9)
            Response.Write(".");
Got this from another forum and could not believe my eyes it worked.
 
Also note if you re-render the page with Page_Init, must it not be loaded here, only when the Only on your reports Load button for example..
 
[edit]Code block added[/edit]
  Permalink  
v2
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 1

Looks like IE10 & Windows8 are yet not supported by Crystal reports, here: http://scn.sap.com/thread/3233406[^]
  Permalink  
Comments
Sandeep Mewara at 17-Apr-13 3:09am
   
Update: As mentioned in my answer, there is no support as of now. The link I have given is of SAP forum (they own crystal reports) where it is clearly discussed and mentioned that as of now it's not supported.
Elayaraja Ponnusamy at 17-Apr-13 5:38am
   
Thank u Sandeep Mewara.........
Sandeep Mewara at 17-Apr-13 5:41am
   
Welcome.
 
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 4

Add this to the head section of your page that contains the report viewer:
 
<meta http-equiv="X-UA-Compatible" content="IE=9,chrome=1" >
 
This will force IE10 to render your page as IE9 automatically to get your report working. HTH
  Permalink  
Comments
Kankunnen at 19-Jul-13 9:27am
   
Hi Marc,
 
I tried this meta thing you mentioned, but did not work for me.
I am not really a black-belt master of asp.net,
so could you check me code below whether or not I put that meta tag into a right place in the code?
 
Thanks in advance for your help!
 

...
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<title>pgeReportCaller</title>
<meta http-equiv="X-UA-Compatible" content="IE=9" />
<meta name="GENERATOR" content="Microsoft Visual Studio 7.0" />
<meta name="CODE_LANGUAGE" content="C#" />
<meta name="vs_defaultClientScript" content="JavaScript" />
<meta name="vs_targetSchema" content="http://schemas.microsoft.com/intellisense/ie5" />

<link href="../Common/eldoradoRSStyle.css" rel="stylesheet" type="text/css" />
 
<script type="text/javascript" language="javascript">
</script>
 
</head>
<body>
<manas:Message ID="Message1" runat="server">
<form id="form1" method="post" runat="server">
 
<cr:CrystalReportViewer ID="CrystalReportViewer1" runat="server" AutoDataBind="True"
Width="350px" Height="50px" ReuseParameterValuesOnRefresh="False">
</form>
</body>
</html>
Marc Gabrie at 19-Jul-13 10:21am
   
Add the following line BEFORE the <html xmlns="...">
 
<!DOCTYPE html>
Kankunnen at 19-Jul-13 17:27pm
   
Hi Marc,
 
thank you for your quick answer.
Please see below the full code of the page.
That meta tag is in the <head> section of the page. Is there anything else I might need to change/set? Or it should work as it is now?
If I try the 'Solution 3' (Response.Write(".") thing) it works for me.
But this solution you posted looks more 'conscious' and nicer so I would try this first to make it work :).
 
<%@ Register TagPrefix="cr" Namespace="CrystalDecisions.Web" Assembly="CrystalDecisions.Web, Version=13.0.2000.0, Culture=neutral, PublicKeyToken=692fbea5521e1304" %>
 
<%@ Page Language="c#" Inherits="ReportServer.Reports.pgeReportCaller" CodeFile="pgeReportCaller.aspx.cs" %>
 
<%@ Register TagPrefix="manas" TagName="Message" Src="../Controls/CtlMessage.ascx" %>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
 
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<title>pgeReportCaller</title>
<meta http-equiv="X-UA-Compatible" content="IE=8" />
<meta name="GENERATOR" content="Microsoft Visual Studio 7.0" />
<meta name="CODE_LANGUAGE" content="C#" />
<meta name="vs_defaultClientScript" content="JavaScript" />
<meta name="vs_targetSchema" content="http://schemas.microsoft.com/intellisense/ie5" />

<link href="../Common/eldoradoRSStyle.css" rel="stylesheet" type="text/css" />
 
<script type="text/javascript" language="javascript">
</script>
 
</head>
<body>
<manas:Message ID="Message1" runat="server">
<form id="form1" method="post" runat="server">
 
<cr:CrystalReportViewer ID="CrystalReportViewer1" runat="server" AutoDataBind="True"
Width="350px" Height="50px" ReuseParameterValuesOnRefresh="False">
</form>
</body>
</html>
Marc Gabrie at 19-Jul-13 18:28pm
   
To get the meta tag applied, you must change the DOCTYPE as I told you before. You have this:
 
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
 
Modify it so it looks like this simple line:
 
<!DOCTYPE html>
 
And maybe you must change this line:
 
<html xmlns="http://www.w3.org/1999/xhtml">
 
to just this:
 
<html lang="en">
Kankunnen at 30-Jul-13 6:19am
   
Hi Marc,
Thank you for your quick answers!!!
 
Just as a closure of this discussion, here is how we were able to solve this problem finally.
Our site is an old site, it still uses framesets/frames. (I did not think that this could play any role but it seems it did :)).
All we needed to do was to remove the !DOCTYPE directive from the page that displays the report... and then the page and the report worked like a charm.
Apparently this 'behavior' is specific to framesets.
 
If the page that displays the report is not using frames the <meta http-equiv="x-ua-compatible" content="IE=9" /> is still required.
Marc Gabrie at 30-Jul-13 11:46am
   
you're welcome! I'm glad to hear you got it working and thanks for sharing your solution as it'll help someone else experiencing the same issue
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 5

Try Setting
HasDrilldownTabs="False"
Example
<CR:CrystalReportViewer ID="CrystalReportViewer1" runat="server" AutoDataBind="true" ReportSourceID="CrystalReportSource1"
                        HasDrilldownTabs="False"/>
 
Same is working in my case
 
Thanks
  Permalink  

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
0 OriginalGriff 195
1 ProgramFOX 130
2 Maciej Los 105
3 Sergey Alexandrovich Kryukov 105
4 Afzaal Ahmad Zeeshan 82
0 OriginalGriff 6,564
1 Sergey Alexandrovich Kryukov 6,048
2 DamithSL 5,228
3 Manas Bhardwaj 4,717
4 Maciej Los 4,150


Advertise | Privacy | Mobile
Web02 | 2.8.1411022.1 | Last Updated 16 Jan 2014
Copyright © CodeProject, 1999-2014
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100