Click here to Skip to main content
15,883,705 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
am getting the following error when attempting to run an MVC website in VS2013 and SQl Server 2014 using the ReportViewer control and accessing a report from the report server:

RSExecutionConnection MissingEndpointException: The attempt to connect to the report server failed. Check your connection information and that the report server is a compatible version.

I am using the correct report server url foun in the Reporting Services configuration manager. When I attempt to run the report in the SSRS project, the system prompts me for a user name and password. I enter the computer admin user/password. The report then runs. By the way, the reportviewer control uses the same user/password.

I am also able to access both the report server and reports urls in a browser with the same prompt for user//password.

I tried fiddling around with the report server role settings and under folder settings, this user has all privileges checked (browser, content manager, my reports, publisher, report builder).

Also as a side issue, I cannot see site settings even if I invoke the browser as an administrator.

I also looked in the SSRS Configuration manager. The service account is "Local System". The same admin user is listed in "Execution Account".

When running the website, I see no error entries in the SSRS log.

Please help, I have been looking into this for 2 days.
Posted

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900