Click here to Skip to main content
15,849,768 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
I'm self learning Hadoop and started of with installing Cloudera QuickStart on a VMware Workstation running CENT OS.

I was under the impression that Quickstart VM has most the of configurations predefined. Do I need to set up any other configurations to set up data and name node? Reason being when I type JFS I get only

[cloudera@quickstart bin]$ jps

9480 RunJar

18607 Jps 6952

org.eclipse.equinox.launcher_1.3.0.v20140415-2008.jar


I don't see any data nodes nor name nodes.I looked it up online and solution was to start the daemons using start-all.sh. But I get an error

[cloudera@quickstart hadoop]$ start-all.sh

bash: start-all.sh: command not found
Another round of research landed me in this

As suggested in that answer, when I ran bin/hadoop namenode -format

 [cloudera@quickstart hadoop]$ bin/hadoop namenode -format

bash: bin/hadoop: No such file or directory


I'm stuck in the middle of nowhere with motivation for self study getting really low. Please help with a suggestion and raise up my spirits.

P.S.: I'm an extreme beginner on Hadoop, so please don't be harsh on me if the question looks stupid to you :)

What I have tried:

I have looked up several communities for solution and have embedded those links in the question.
Posted

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900