Click here to Skip to main content
15,313,682 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
Hi Everyone,

Bit of a strange one, that I've not encountered before and is only affecting one view/sql.

I have an oracle view, all of the data is displayed correctly, except one Column (in VS).

If I run the SELECT SQL in SQL Developer I get data in all columns, however if I run the exact same SQL in Visual Studio all the data is displayed, except this one column which comes out as all NULL values (in all rows).

Internal to the VIEW is SUBSTR, however the data resolves to VARCHAR2(200).

Using Visual Studio 2013, ODP.NET, Managed Driver.

Has anyone seen anything like this before?

What I have tried:

Recreating the VIEW.
Running as a Query in the Server Explorer and as DataSource DataTable/Adapter.
Posted
Comments
Bernhard Hiller 21-Sep-16 3:14am
   
Are you sure that the column is really not existing, instead of simply collapsed (but still there)?
Rodimus74 21-Sep-16 19:18pm
   
Thank you for your response.
Yes, the value NULL is displayed.

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900