Click here to Skip to main content
15,902,939 members
Please Sign up or sign in to vote.
1.00/5 (1 vote)
See more:
I am installing sql server 2016 and sql server management studio 2016 in my laptop.
sql server is installed without any problem. but when I tried to install sql server management studio 2016 I got error that "Fatal error during installation(0x80070643).
A valid destination folder for the install could not determined.
I googled no suitable solution found. I installed only one instance of sql server 2016.

My laptop configuration is:

core i5 2.20ghz
16 gb ram
win10 enterprise 64bit
1 TB HDD

What I have tried:

I tried to reinstall several times but same problem every time.
Posted
Updated 29-May-17 20:17pm
v4

1 solution

Here are few threads I got which seems to helped people with same issue.
Please check if these helps-
Quote:
Start regedit and go to (or search for BootstrapDir in registry) :

HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Microsoft SQL Server\130\Bootstrap
In my computer, the BootstrapDir is pointed to :

C:\Program Files (x86)\Microsoft SQL Server\130\Setup Bootstrap\
I changed that to :

C:\Program Files\Microsoft SQL Server\130\Setup Bootstrap\
Then try to reinstall again, it works on my machine.


References:
ssms - A valid destination folder for the install could not be determined when installing SQL Server Management Studio 2016 - Stack Overflow[^]
SSMS 2016 CTP3.2 A valid destination folder for the install could not be determined | Microsoft Connect[^]

Hope, it helps :)
 
Share this answer
 
Comments
vijay_bale 30-May-17 2:22am    
@ Suvendu shekhar Giri
That Setup Bootstrap folder already in my C:\Program Files\Microsoft SQL Server\130
Suvendu Shekhar Giri 30-May-17 2:25am    
Ok. Can you try installing it again as administrator and see if that helps?
vijay_bale 30-May-17 2:28am    
I tried Already but, same problem
vijay_bale 31-May-17 3:46am    
I installed SSMS 17. It installed but one problem came. I am unable to connect database of SQL from my visual studio C#. I tried to create connection but one error came."Unable to add data connection.Could not load file or assembly. Microsoft.SqlServer.Management.Sdk.Sfc, Version=12.0.0.0, Culture=neutral, PublicKeyToken=89845dc8080cc91 or one of its dependincies. The system cannot find the file specified". So I googled for that error and downloaded and installed sqlserver 2016 feature pack. But problem not solved.

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900