Click here to Skip to main content
14,739,187 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
My EXCEL source in SSIS is exposing this error below on the server (local machine). Can someone please advise?

‘Microsoft.ACE.OLEDB.12.0’ provider is not registered on the local machine.

What I have tried:

When I tried with the same SSIS package on a client machine, no problem at all. Why is this NOT happening on the local machine?
Posted
Updated 9-Apr-18 10:37am
v2
Comments
PIEBALDconsult 7-Apr-18 17:34pm
   
That's a very common error and I'm sure a quick search will find you information about the cause.
You may need to download and install the ACE Engine, and/or you may be need to run the SSIS package in 32-bit.

Hi,

Thanks for your article!! I re-saved the Excel file to .xls in the server and the SSIS package is able to execute.
   
Comments
Maciej Los 9-Apr-18 16:04pm
   
Great! I'm glad i can help.
By The Way:
Please remove this "answer", because it is not related to solution and exposes you to downvotes. Such of content has to be posted as a comment (use "Have a question or comment" widget).

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
Top Experts
Last 24hrsThis month



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900