Click here to Skip to main content
15,917,568 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
I have a work assignment that consists of linking two databases on two different computers through SQL Server Management Studio. Basically, both databases have to transmit the same data to a centralized SCADA from some machines that have different tasks.

What I am trying to do is making this connection through Linked Servers. I managed to set up the OCBD server on the first machine with no problems at all. After that I started setting up the connection on the second machine so that they could communicate. I am getting an array of problems but the most common is the one at the bottom.

I have searched plenty of pages for a solution but everyone suggests solutions that have no affect on my project, so i was wondering id anyone knows what is wrong with my settings. If it's not my settings, then could it be some Firewall setting or something along the lines of that.

On the first machine I created an OCDB data source through the Administrative Tools from Windows. On the second machine, through my SQL Server Management Studio I tried creating a new Linked Server and applying the settings suggested here:[^]

Even though I have followed it step by step I still get error: 'Cannot initialize the data source object of OLE DB provider "MSDASQL" for linked server "SERVERNAME".(Microsoft SQL Server, Error: 7399)'

I have already tried to change the settings of the provider and enable "allow inprocess" since one of the pages I consulted, suggested this might be the problem.

Thanks to everyone in advance.

What I have tried:

I have already looked for solutions and applied all the different settings suggested online. Still not working.
Updated 16-Nov-18 4:18am
MadMyche 16-Nov-18 9:48am    
"I tried a bunch of things but they don't work" tells us absolutely nothing about what you have done. Please consider editing your question (Improve Question) to give us a step-by-step of how you linked the 3 servers and what exactly you need.
Member 14056986 16-Nov-18 10:07am    
Beg your pardon, I thought I had uploaded images with my settings and error. I will improve my question right away.
CHill60 16-Nov-18 10:24am    
You can't upload images
Member 14056986 16-Nov-18 10:29am    
Yes, I realized that. That is why I updated my question
ZurdoDev 16-Nov-18 13:21pm    
Just open Sql Management Studio and connect to one Sql server. Expand Server Objects and then right-click on Linked Servers choose to create a new linked server.

Easy peasy.

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900