Click here to Skip to main content
15,881,712 members
Please Sign up or sign in to vote.
1.00/5 (1 vote)
See more:
I have installed VS 2015 SDK for AWS and .NetCore 1.0 as a prerequisite for deployment.

While trying to deploy from Publish to AWS Lambda.. by right click on project, I am getting below error

"No .NET project found in directory D:\SampleProjects\AWSServerless1\AWSLambda1\AWSLambda1 to build. "

How do I resolve this issue?


What I have tried:

I have tried all possible solutions by uninstalling and re-installing but of no use.
Posted
Updated 24-Feb-19 4:51am

1 solution

The error message says that there are no projects in the directory. From what I can see—and from what you have shared—I can only suggest that you check why the tool is trying to find the project in that directory, it seems to be in, "AWSServerless1\AWSLambda1" directory. The project is a .csproj file, you can verify where that project file is and then check why that SDK is using a different directory.

Take a look at this[^] sample code for more. This shows how you can use CLI and tools to build the project and then test it, this assume that you have downloaded the SDK too.
 
Share this answer
 
Comments
Ashishmau 25-Feb-19 5:42am    
I am using .NetCore 1.0 in which project file have extension .xproj.
Its publishing successfully using CLI but not through AWS provided GUI.

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900