Click here to Skip to main content
15,441,629 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
Team,

Creating Setup file using INNO Tool and execute the setup file in windows 10 OS, and issue showing,
Unable to execute File:
c:\Program Files (X86)\Setup1\Test.exe
createprocess failed; code 740.
the requested operation requires elevation.
check below image,
https://i.stack.imgur.com/mtgGK.png[^]
Please provide how to resolve this issue.
I have used sqlite database in my project.

thanks.

What I have tried:

I have tried using with encryption and without encryption, using IntelliLock Tool for assembly security purpose. but not able to rectify it.
Posted
Updated 27-Mar-19 0:02am
v3

Read the error message:
the requested operation requires elevation.

The app you are trying to run from your setup needs admin access - and it doesn't have it. Either modify the app to not require admin privileges, or modify your install script to provide them.
 
Share this answer
 
In addition to solution #1 by OriginalGriff, i'd suggest to read this: Inno Setup Help => [Setup]: PrivilegesRequired[^]

You can force Setup to run in admin mode, but...
Quote:
If Setup was started by an unprivileged user, Windows will ask for the password to an account that has administrative privileges, and Setup will then run under that account.
 
Share this answer
 

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900