Click here to Skip to main content
15,882,796 members
Please Sign up or sign in to vote.
1.17/5 (4 votes)
See more: , +
Hi,
I have been coming across this error very very often.
"A data source instance has not been supplied for the data source"

Please advise why it comes and how to fix it.

I googled it but did not get any solid method to fix it.

Thanks
Furqan

Update from OP:
OP resolved the issue himself and posted the resolution as answer.
Posted
Updated 18-Sep-18 0:42am
v2
Comments
Ashok.C.Patil 23-Dec-11 8:31am    
I am facing error A data source instance has not been supplied for the data source

I just found the way to fix it.

Got o your ReportViwer that carries the report.
Click on the triangle above and click
Choose Data Sources. Here you will find the binding sources in in your data sets.
Just choose your binding source and you are done.
 
Share this answer
 
Comments
Sagotharan Jagadeeswaran 8-Apr-11 5:44am    
i have the same error.
but i cant find the triangle in reportviewer. Iam using wpf.
joeller 12-Aug-13 15:16pm    
Does not work. No datasources listed in "choose datasources"
Bill Headley 19-May-11 15:44pm    
Thank you! I was pulling my hair out before stumbling on your suggestion.
Member 10224892 23-Aug-13 7:12am    
not working
evdjramos 8-Sep-11 22:35pm    
It works!
Thank you!!
I had the same problem, with 3 datasources in the report while i only used 1.

It looks like i caused this by referencing the same datatable, from multiple datasets.

I removed all extra references to datasources in the form's designer page.

But when i click on the report, to select the datasource all three where still there.

One solution that worked, was to click on the report, and set all datasource instances to the correct dataset-datatable.

But the correct solution that solved the problem, was to edit the report.rdlc file with notepad.

There you will find under "datasets", a section for each datasource.

Carefully delete the sections for the datasets you dont want, problem solved..

Regards

John van Eijck
 
Share this answer
 
v2
Comments
kohinoorhingu 15-Oct-13 3:33am    
I want to create rdlc report without dataset, means i call report from code, then how can i develop it? please helpppp.....
Member 12068634 4-Feb-16 3:41am    
what about passing rdl file direct from report server???? I am having the same problem too.
I also have this error "A data source instance has not been supplied for the data source"
I have two binding source to bind to. How do I remove one of them?
 
Share this answer
 
Comments
SITU.PATI 15-Oct-14 5:31am    
i have one dataset bt still the same problem exits

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
Top Experts
Last 24hrsThis month


CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900