Click here to Skip to main content
14,112,835 members
Rate this:
 
Please Sign up or sign in to vote.
Hallo everybody,

I did try again and again to add ReportViewer control into the toolbox,it is checked but couldn't be viewed in the choose item.

I don't know how to solve this.

This only happens when the project is Asp.Net application. It is visible when the project is windows application.

Thanks
Posted
Updated 8-Sep-18 2:24am
v2
Comments
Ruard 1-Jun-11 3:35am
   
What version of visual studio are you using and what version of reportviewer did you install?
Yonathan1111 1-Jun-11 4:17am
   
Visual Studio 10 and Microsoft ReportViewer 2010 Redistributable (10.0.30319).
I think I found the version, actually there are three versions of ReportViewer Controls in the Assembly by the name of Microsoft.ReportViewer.WebForms, which are (9.0.0.0, 8.0.0.0, and 10.0.0.0).
But, I don't know what to do.

Thanks
Yonathan1111 1-Jun-11 3:40am
   
Visual Studio 10 and Microsoft ReportViewer 2010 Redistributable (10.0.30319).
I am not certain how to get the version of the ReportViewer Control.
Thanks
Yonathan1111 1-Jun-11 3:46am
   
I think I found the version, actually there are three versions of ReportViewer Controls in the Assembly by the name of Microsoft.ReportViewer.WebForms, which are (9.0.0.0, 8.0.0.0, and 10.0.0.0).
But, I don't know what to do.
Rate this: bad
 
good
Please Sign up or sign in to vote.

Solution 1

Since you can see the reportviewer for forms: please note that you select Microsoft.Reporting.WebForms for asp.net.

Do you see the tab 'Reporting' in your toolbox? This should contain MicrosoftReportViewer. If not, try reinstalling the redistributable(s).

But do you really need it in your toolbox? You can also add the following line to your page (you can change the version also to 10.0.0.0).

<%@ Register assembly="Microsoft.ReportViewer.WebForms, Version=9.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" namespace="Microsoft.Reporting.WebForms" tagprefix="rsweb" %>


And the actual reportviewer:

<rsweb:ReportViewer ID="ReportViewer1" runat="server" Font-Names="Verdana" Font-Size="8pt" ShowRefreshButton="False" Width="790px">
</rsweb:ReportViewer>

If this works you at least have a work-around.
   
Rate this: bad
 
good
Please Sign up or sign in to vote.

Solution 2

1. Right Click on Toolbox and check "Show All"
There are two reportviewer in reporting tab.
2. Right click again and click "Choose Items..."
3. Disable ReportViewer in ".Net Framework Components" tab and click Ok
Reportviewer will dissappear.
4. Right click again and click "Choose Items..."
5. Enable ReportViewer in ".Net Framework Components" tab and click Ok
Just one ReportViewer icon will show in reporting tab
6. Right Click on Toolbox and uncheck "Show All"
Reporting tab will not dissappear
   
Rate this: bad
 
good
Please Sign up or sign in to vote.

Solution 4

re VS 2107 and WinForms
Solution 2 is along the right lines. This is what I did;
1) From Extensions and Updates, download and install Microsoft RDLC Report Designer
2) As in Solution 2, go into Toolbox, select a section where you want the ReportViewer to appear. Right click and select Choose Items.
3) Scroll down the list, you should see two entries for Report Viewer. Make sure you tick the one for WinForms.
4) The ReportViewer control should appear in your chosen Toolbox section (Printing in my case).
5) Drag the control onto a Form and Voila!, ReportViewer1 should appear.
6) Notice two references have been added to your project;
Microsoft.ReportViewer.Common
Microsoft.ReportViewer.Winforms
   
v2

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
Top Experts
Last 24hrsThis month


Advertise | Privacy | Cookies | Terms of Service
Web05 | 2.8.190518.1 | Last Updated 8 Sep 2018
Copyright © CodeProject, 1999-2019
All Rights Reserved.
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100