Click here to Skip to main content
14,330,663 members
Rate this:
Please Sign up or sign in to vote.
See more:
While running project all class library classes get read only and brakepoints turn empty and say "Breakpoint will not currently be hit. No symbols loaded for this document". Never had problem with it before.

Configuration manager shows library class as in debug so what's the problem.

Its a application that runs on windows mobile emulator for debugging purpose.

Help appreciated as I haven't found solution for it on internet yet.

So how to debug it?
Posted
Updated 9-Oct-19 23:29pm
v2
Rate this:
Please Sign up or sign in to vote.

Solution 3

Try this

set "Generate DEBUG information" to FALSE
delete /bin and /obj folder
Set "Generate DEBUG information" back to TRUE
rebuild the project


This generally occurs when the dll and the dll source code both are different
or if the .pdb file information is not matching.
   
v2
Comments
mateusz.matyaszek 27-Sep-11 8:41am
   
Tried that and no joy. Even tried adding pdb file location through Symbols but no joy either.
mateusz.matyaszek 27-Sep-11 9:44am
   
Am I dreaming or there is a window in VS that shows what Symbols are loaded
surendrav 4-Jan-12 6:54am
   
check if you are Debugging in Release Mode :)
Rate this:
Please Sign up or sign in to vote.

Solution 4

Well solution was easier than that. I was having wrong file open (from different project because I was using search in mindless way).
   
Rate this:
Please Sign up or sign in to vote.

Solution 1

Check the location of executable, does the executable and all associated libraries have been uploaded to emulator. This happens when you try to debug an older version executable towards a new code base.
   
Comments
mateusz.matyaszek 27-Sep-11 5:49am
   
How would I do that?
Rate this:
Please Sign up or sign in to vote.

Solution 5

close all your tab in the browser just run your application only.
   
Comments
Member 12836623 9-Jan-18 8:39am
   
I wasted five long hours trying to resolve this. But, this did it for me. This is while i was under pressure to deliver on a project. i tried all sorts of suggestions to no avail. Thanks a million, Grace
Max pk 27-Sep-18 16:51pm
   
browser tabs have nothing to do with symbols, instead it may give you some free memory
Rate this:
Please Sign up or sign in to vote.

Solution 14

If you have multiple projects in a single solution, select a project as startup project. Right click on the project you want to set as a startup project and click on "Set as a Startup Project". It worked for me. Hope so it will work for you.
   

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
Top Experts
Last 24hrsThis month



CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100