Click here to Skip to main content
15,902,899 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
I'm using Asp.net 3.5 on Godaddy, and I need a way for users to upload large files using Asp.net FileUpload Control, I don't want to use a third party

I've changed the value of maxRequestLength in web.config as follows:
HTML
<httpRuntime executionTimeout="1100" maxRequestLength="512000" />


but when uploding a file of about 32 MB, upload process goes well (I can see percentage for the process in the down-left corner of Chrome browser), but after a while, the process restarts !! and after going with upload for a while page crashes without errors (just telling me that page cannot be displayed)

The same happens on IE (but of course without percentage)

Please help me to solve this issue without third party
Posted
Updated 4-Oct-11 16:12pm
v2
Comments
Vallel Alejandro Blanco Achoy 20-Apr-12 19:13pm    
How did you solve this issue? I'm having the same problem

1 solution

This setting goes in your web.config file. It affects the entire application, though... I don't think you can set it per page.
XML
<configuration>
  <system.web>
    <httpRuntime maxRequestLength="xxx" />
  </system.web>
</configuration>


"xxx" is in KB, the default is 4096 (= 4 MB).

I tried it for 10240(10 MB) and it works for me.

Was this post useful to you?

Thanks
Murugan
 
Share this answer
 
v2
Comments
Ahmad Safwat 5-Oct-11 8:56am    
Thank you for your answer, but I've done that as I posted above

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900