Click here to Skip to main content
15,942,407 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
After deploying my web application in server IIS 7.5.

And when I am trying to run it It's showing the error like.

500 - Internal server error.
There is a problem with the resource you are looking for, and it cannot be displayed


In my local it's working fine. through google I came to know that error lies in web.config file..but I could not solve it.

Here's my server web.config file.
HTML
<!--
  For more information on how to configure your ASP.NET application, please visit
  http://go.microsoft.com/fwlink/?LinkId=169433
  -->
<configuration>
  <appsettings>
    <add key="ChartImageHandler" value="storage=file;timeout=20;" />
  </appsettings>
  <connectionstrings>
    <add name="ApplicationServices" connectionstring="Data Source=ITCSERVER;Initial Catalog=ForecasteChart;User ID=weblogin;Password=Mazha$villu@77504" providername="System.Data.SqlClient" />
    <add name="strforecastConnectionString" connectionstring="Data Source=ITCSERVER;Initial Catalog=ForecasteChart;User ID=weblogin;Password=Mazha$villu@77504" providername="System.Data.SqlClient" />
    <!--<add name="strforecastConnectionString" connectionstring="Data Source=PRADEEP\SQLEXPRESS;Initial Catalog=ForecasteChart;User ID=sa;Password=sa123" providername="System.Data.SqlClient" />
    <add name="ApplicationServices" connectionstring="Data Source=PRADEEP\SQLEXPRESS;Initial Catalog=ForecasteChart;User ID=sa;Password=sa123" providername="System.Data.SqlClient" />-->
  </connectionstrings>
  <system.web>
    <httphandlers>
      <add path="ChartImg.axd" verb="GET,HEAD,POST" type="System.Web.UI.DataVisualization.Charting.ChartHttpHandler, System.Web.DataVisualization, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35">
       validate="false" />
    </add></httphandlers>
    <pages>
      <controls>
        <add tagprefix="asp" namespace="System.Web.UI.DataVisualization.Charting">
         assembly="System.Web.DataVisualization, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" />
      </add></controls>
    </pages>
    <customerrors mode="Off" />
    <compilation debug="true" targetframework="4.0">
      <assemblies>
        <add assembly="System.Web.DataVisualization, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
      </assemblies>
    </compilation>
    <authentication mode="Forms">
      <forms loginUrl="~/Account/Login.aspx" timeout="2880"/>
    </authentication>
    <membership>
      <providers>
        <clear />
        <add name="AspNetSqlMembershipProvider" type="System.Web.Security.SqlMembershipProvider" connectionstringname="ApplicationServices" enablepasswordretrieval="false" enablepasswordreset="true" requiresquestionandanswer="false" requiresuniqueemail="false" maxinvalidpasswordattempts="5" minrequiredpasswordlength="6" minrequirednonalphanumericcharacters="0" passwordattemptwindow="10" applicationname="/" />
      </providers>
    </membership>
    <profile>
      <providers>
        <clear />
        <add name="AspNetSqlProfileProvider" type="System.Web.Profile.SqlProfileProvider" connectionstringname="ApplicationServices" applicationname="/" />
      </providers>
    </profile>
    <rolemanager enabled="false">
      <providers>
        <clear />
        <add name="AspNetSqlRoleProvider" type="System.Web.Security.SqlRoleProvider" connectionstringname="ApplicationServices" applicationname="/" />
        <add name="AspNetWindowsTokenRoleProvider" type="System.Web.Security.WindowsTokenRoleProvider" applicationname="/" />
      </providers>
    </rolemanager>
  </system.web>
  <system.webserver>
    <modules runallmanagedmodulesforallrequests="true" />
    <handlers>
      <remove name="ChartImageHandler" />
      <add name="ChartImageHandler" precondition="integratedMode" verb="GET,HEAD,POST">
       path="ChartImg.axd" type="System.Web.UI.DataVisualization.Charting.ChartHttpHandler, System.Web.DataVisualization, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" />
    </add></handlers>
  </system.webserver>
</configuration>


Any help?

Thank u
Pradeep Anugu.
Posted
Updated 10-Nov-11 3:10am
v4

1 solution

 
Share this answer
 

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900