Click here to Skip to main content
13,735,471 members
Rate this:
 
Please Sign up or sign in to vote.
See more:
Hi all!!!

I created a database owner in sql-server 2008. I set authentication type to sql server authentication , added username and password to it then set the user mapping for this user to be database owner.

Now when i am trying to run management studio using sql sever authentication , it's showing me this error

A connection was successfully established with the server, but then an error occurred during the login process. (provider: Shared Memory Provider, error: 0 - No process is on the other end of the pipe.) (.Net SqlClient Data Provider)


I tried to find solution on google but can't find any specific solution.
Posted 28-Mar-12 22:16pm
Updated 4-Oct-18 10:37am
Rate this: bad
 
good
Please Sign up or sign in to vote.

Solution 8

Issue resolved after I have started the SQL Browser service which was disable and stooped before.
  Permalink  
Comments
CHill60 1-Jun-17 18:39pm
   
Why have you resurrected a 5 year old question from someone else to inform us that you have solved your own problem?
Rate this: bad
 
good
Please Sign up or sign in to vote.

Solution 1

This error happens becasue the named pipe support is not enabled for your SQL server.To enable named pipes or for workarounds see the link http://msdn.microsoft.com/en-us/library/ms175496(v=sql.110).aspx[^]
  Permalink  
Rate this: bad
 
good
Please Sign up or sign in to vote.

Solution 5

Hi,

I faced similar issue today, In my case I had a default database associated with user. It was other than master. I deleted the database and when next time I tried to login via Management studio it started giving error.

I went to options tab of connection dialog and specified default = master.

It worked for me.

Thanks,
Nimesh
  Permalink  
Rate this: bad
 
good
Please Sign up or sign in to vote.

Solution 2

  Permalink  
v3
Rate this: bad
 
good
Please Sign up or sign in to vote.

Solution 3

For my case, resolve using [Surface Area Configuration] set the [Local and remote connections] to [Using TCP/IP only].
  Permalink  
Comments
CHill60 27-Jul-13 8:50am
   
Which is what solution 1 said to do a year ago
Rate this: bad
 
good
Please Sign up or sign in to vote.

Solution 4

this can be useful in troubleshooting sql 2012, basically the connection is there but fails on login. therefore to resolve this issue, change the authentication to sql authentication, login with your sa account and add your acoount or domain account you want to have access and voila it works!. hope this helps
  Permalink  
Comments
CHill60 27-Jul-13 8:51am
   
Did you realise that this question is over a year old?
Rate this: bad
 
good
Please Sign up or sign in to vote.

Solution 7

Hi All,

I faced the same issue once and what I did was

1. I stopped all other services (Analysis, integration and reporting services) and restarted the MSSQLSERVER service.
2. Then I was able to connect to database engine using SSMS.
3. Properties > Connection > Changed the value into 0 (Unlimited).

Of course this was not a production environment.
  Permalink  
Rate this: bad
 
good
Please Sign up or sign in to vote.

Solution 9

I face this issue and this link work for me

Change Server Authentication Mode | Microsoft Docs[^]
  Permalink  
Rate this: bad
 
good
Please Sign up or sign in to vote.

Solution 10

The SQL Server login I was using was setup to require the password to be changed at the next login. Once I reset the password my issue was resolved.
  Permalink  

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
Top Experts
Last 24hrsThis month


Advertise | Privacy | Cookies | Terms of Service
Web05-2016 | 2.8.180920.1 | Last Updated 4 Oct 2018
Copyright © CodeProject, 1999-2018
All Rights Reserved.
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100