Click here to Skip to main content
13,089,818 members (46,715 online)
Rate this:
Please Sign up or sign in to vote.
Hi I've developed a web application in c# and (.net 3.5 framework). I am now trying to deploy this application 'live' onto my local machine to ensure that it runs smoothly etc. before actually deploying onto the live system for other users to access. I've created web setup project(QuantumWeb) as part of my Project and added the Content files and Primary output files in the Web Application Folder of the QuantumWeb SetUp.

I've ran the setup on my local using the default values for the Installation Address pop-up (Site: Default Web Site / Virtual Directory: QuantumWeb / App Pool: DefualtAppPool) which creates the following directory: C:\inetpub\wwwroot\QuantumWeb

Within IIS i have set the Default Document to Login.aspx but when I try to browse to this login page via: http://localhost/quantumweb/login.aspx I am getting the following error and I do not understand why:

Server Error in '/' Application.

The resource cannot be found.

Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable. Please review the following URL and make sure that it is spelled correctly.

Requested URL: /login.aspx

Version Information: Microsoft .NET Framework Version:2.0.50727.4927; ASP.NET Version:2.0.50727.4927

I've did a bit of googling on this and so far nothing has worked so i'm hoping that someone here can provide me with some insightful instructions of things to check i.e. settings etc or else point me in the right direction to resolving this issue.

thanks in advance
Posted 19-Jun-12 1:20am
ryanb31 19-Jun-12 8:08am
So, something may be off with the url. Go into IIS Manager and right-click the login.aspx file and choose Browse and see what the URL is.
Rate this: bad
Please Sign up or sign in to vote.

Solution 1

hi ,

this is happen because your default application pool is using .net framework v 2.0
and your project is developed using 3.5.

check .net framework 3.5 is available in your IIS sever application pool then use the same pool for your application

otherwise you can install and register framework 3.5 on your server

this link [^] will help you
pmcm 19-Jun-12 9:18am
I'm trying to do this on my local machine first of all, and yes you are correct I only have Application Pools for 2.0 and 4.0 .NET Framework. If I download .NET FW 3.5 onto my machine will this cause any problems as I already have .NET FW 4.0?
pmcm 19-Jun-12 10:08am
I've found this on another website - looks like 3.5 uses the 2.0 App Pools: ".NET 3.5 still runs on the 2.0 CLR. The framework versions 3.0 and 3.5 only added to the Base Class Library and added additional frameworks. 3.0 added WCF, WPF, and Workflow. It also contained a lot of the base framework additions for Linq which was added in 3.5. These still run on the 2.0 CLR. Framework version 4.0 also came with an upgrade to the CLR."
Rate this: bad
Please Sign up or sign in to vote.

Solution 2

Go into IIS manager, select your directory QuantumWeb, click on Feature view,open 'Directory browsing' and enabled it. then restart your IIS and then browse. it may be help. let me know if it helps you.
pmcm 19-Jun-12 9:18am
I have tried this step already and it never helped

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
Top Experts
Last 24hrsThis month

Advertise | Privacy |
Web03 | 2.8.170813.1 | Last Updated 19 Jun 2012
Copyright © CodeProject, 1999-2017
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100