Click here to Skip to main content
13,148,173 members (33,000 online)
Rate this:
 
Please Sign up or sign in to vote.
hi,

I am successfully loaded user control dynamically on AJAX tab container
here is the code

1)
Dim UserControl_3 As ASP.inpatienteditbill_ascx = New ASP.inpatienteditbill_ascx


2)
UserControl_1.LoadControl("~/InpatientEditBill.ascx")
  TabPanel3.Controls.Add(UserControl_3)


Question is,

I have lots of controls with in user controller, such as grid view, drop downs, buttons...

when I click the button in user control its disappear, and when click on the tab its get loaded, but the form load event doesn't get invoke.
plz help me.
Posted 23-Sep-12 21:13pm
v2

1 solution

Rate this: bad
 
good
Please Sign up or sign in to vote.

Solution 1

hi,
might be it is problem of postback..check out that..
when u click on button within user control then page is postback then usercontrol disappears but when u click on tab then it load usercontrol again...
  Permalink  
Comments
sawshalin 24-Sep-12 4:22am
   
post backs are working fine,when i bind them to main page source,
<contenttemplate>
uc3:WebUserControl3 ID="WebUserControl3" runat="server"

what i need is load user controls dynamically(already done),but form load event of user control is not firing and when click the button on user control its get lost

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
Top Experts
Last 24hrsThis month


Advertise | Privacy |
Web02 | 2.8.170924.2 | Last Updated 24 Sep 2012
Copyright © CodeProject, 1999-2017
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100