Click here to Skip to main content
15,881,089 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
i use ajax to insert data into tables but whenn i click on save button it give me an error that says
http://localhost:49895/Home/Create 500 (Internal Server Error)
send @ jquery-1.8.3.min.js:2
ajax @ jquery-1.8.3.min.js:2
(anonymous) @ Create:542
dispatch @ jquery-1.8.3.min.js:2
u @ jquery-1.8.3.min.js:2

What I have tried:

i have tried inetmgr to mange this issue but failed
Posted
Comments
Richard MacCutchan 7-Nov-19 6:07am    
You need to inspect the server logs. There is no way anyone here can guess what is happening to cause that.
F-ES Sitecore 7-Nov-19 6:16am    
It's the code at the target url ("Create") that is throwing the error. You need to debug\log the code that executes on that action to find out what the problem is.
Member 14552976 7-Nov-19 6:28am    
i have used debugger but it give undefined value of textbox
Richard MacCutchan 7-Nov-19 6:44am    
Well that is a good clue; something that you are passing through the connection is not valid.
Afzaal Ahmad Zeeshan 7-Nov-19 7:33am    
That problem is with the server-side code, your jQuery is fine.

Add a breakpoint on the Create function and debug it.

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900