Click here to Skip to main content
15,900,818 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
I have a asp.net application. In localhost if I run the application using IE the application runs as expected. If I run the application in Edge i get - 'HTTP Error 401.2 - Unauthorized' error

Application uses windows authentication In IE I will not get Username password dialog. In Edge after I run the code localhost The username password box repeats when I close it above error message is displayed.


What I have tried:

I tried running in chrome there also I am getting same issue
Posted
Updated 11-Sep-20 4:04am

Windows login prompt dialog is an internet setting and the default setting is "Automatic logon only in Intranet zone". Please make sure this setting is enabled for edge.

Quote Refer[^]:
For Edge, a server is recognized as part of the local intranet security zone when the user specifies a URL with a fully qualified name that has been explicitly configured as a local intranet site in Edge (see instructions below).

1. Open the Windows Settings and search Internet Options.
2. Click Local intranet > Sites
3. Click Advanced.
4. Enter the tenant specific URL into the Websites text box.
5. Click Close.

Other things to validate for your app:
Have Windows authentication and authorization enabled for your ASP.NET app[^]
Web page pop-up username and password box - Browsers | Microsoft Docs[^]
 
Share this answer
 
Google "edge windows authentication" - some pages have things to try, but it seems like Edge might just not support Windows Authentication.

single sign on - Integrated Windows authentication in Microsoft Edge - Stack Overflow[^]
 
Share this answer
 

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900