Click here to Skip to main content
15,559,491 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
Hi ,
I have a wired problem , that my application working fine on all our customer , we created a service user to enable the authentication on AD , but one customer showed that it will work only with "Domain administrator", when we are using our service user , it will not work , they are using AD 2019 .

With our service user we got this message :
System.componentModel Win32Exception 0x80004005


I know it is for sure a permission issue , my question is what permission should request from vendor to validate this authentication .


Thanks

What I have tried:

We tried to use domain administrator , the system works like a charm, if we use our user or any other user will have the same error .
Posted
Updated 26-Mar-21 2:43am
Comments
Garth J Lancaster 9-Jan-21 19:46pm    
Can you dump/list permissions on the service account at a customer where it does work, then compare against a customer where it doesnt ? (you'd need pretty understanding customer I guess)

The issue was in folder permission , the folder need EXECUTE permission to run the scripts for other domain users , after applying the folder permssion in initpub subfolder (the site location ) , it workded like a charm .
 
Share this answer
 

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900