Click here to Skip to main content
15,346,659 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
i had crystal report 8.5 and i used used crytal report button to open crystal report.
the coding which i used was as below

CrystalReport1.ReportFileName = App.Path & "Path"
CrystalReport1.RetrieveDataFiles
Set CrystalReport1.DataSource = QNrs
CrystalReport1.Action = 1

but after i change to crystal report 11 its giving me errors on this coding. i have added the references and components to CR11.

i dont want the report to open with in vb by using CrystalActiveXReportViewer. any ideas how to open it like i used when using CR8.5.

i want to use crystal report controller so that the report wont open in a form.

What I have tried:

i used crystalactivexreportviewer and am able to veiw it using it but since its opening in a vb form it looks very odd.
Posted
Updated 21-Sep-21 16:27pm
v6
Comments
Richard Deeming 21-Sep-21 10:05am
   
If you want someone to help you fix an error, you need to tell us what the error(s) are. Click the green "Improve question" link and update your question to include the full details of the errors, and remember to indicate which line of code they relate to.

NB: VB6 has been "dead" for two decades now. You'll probably struggle to find anyone who is still using it.
Member 15329613 21-Sep-21 10:26am
   
What is the error?
Pulith Jayasuriya 21-Sep-21 11:55am
   
error 20525 on run time
Member 15329613 21-Sep-21 13:21pm
   
On which line of code?
Pulith Jayasuriya 21-Sep-21 13:57pm
   
CrystalReport1.RetrieveDataFiles
Member 15329613 21-Sep-21 13:23pm
   
It sounds like you might have a conflict of dlls.
Pulith Jayasuriya 21-Sep-21 13:57pm
   
yeah it seems to be but i just cant find away to sort it.
Member 15329613 21-Sep-21 14:09pm
   
Here's something that worked for somebody: https://www.toolbox.com/tech/programming/question/run-time-error-20525-092107/
Richard Deeming 22-Sep-21 4:27am
   
A link to a page which contains nothing but a link to a heavily obfuscated script file?

Yeah, that doesn't smell of malware at all. 🤦‍♂️
Member 15329613 22-Sep-21 7:12am
   
Your internet is broken, :), when I go to that link it is a forum posting and the last posting reads:

"i faced the same problem while using cystal report 11 and i used to copy the file crpe32.dll from the new installed folder to c:windowssystem32 and it works fine"
Richard Deeming 22-Sep-21 7:47am
   
They're doing user-agent sniffing. If I make the request using a default UA, I get a full HTML page back. If I make the request using the Firefox UA, I get:
<html>
<head>
<META NAME="robots" CONTENT="noindex,nofollow">
<script src="/_Incapsula_Resource?SWJIYLWA=5074a744e2e3d891814e9a2dace20bd4,719d34d31c8e3a6e6fffd425f7e032f3">
</script>
<body>
</body></html>
Member 15329613 22-Sep-21 10:03am
   
Weird. If I use FireFox I get the same thing as I do in chrome.

Works for me. :)
Richard Deeming 22-Sep-21 7:54am
   
If I request the _Incapsule_Resource without a referrer, I get a protocol violation error. If I add the first URL as the referrer, I get a heavily-obfuscated Javascript file.

Deobfuscating the code leads to another obfuscated code.

The site is very clearly infected with malware.

You should post the question at Error 20525 | SAP Community[^].
   
I have spent many hours on Crystal.
I have found newer versions of reports will run with older libraries of Crystal.

I suggest creating a new Crystal Report with v11.
Make sure you can access the data w the new report prior to attempting any access via automation.
Replace your old rpt w the new v11 rpt and try it; making backups so can go back.

Good Luck!
   
Comments
Pulith Jayasuriya 21-Sep-21 22:13pm
   
hi, i tired it but i am yet getting the same error "run time error '20525' unable to load report"

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900