Click here to Skip to main content
15,901,205 members
Please Sign up or sign in to vote.
1.00/5 (2 votes)
See more:
Hello !
When I trying to make a call in the api using “https://login.uber.com/oauth/v2/token” an "error" error is returned: "invalid_scope".

I provide the authentication correctly and the scope on the dashboard is correctly configured as well as the permission grants.

parameter explanation:

client_id (string) The Client ID of your application.
client_secret (string) The Client Secret of your application.
grant_type (string) In this step, this should be set to client_credentials.
scope (string) The space delimited list of scopes.

An integration always worked, but this scope error started to occur. I followed documents Here the documentation about that : Uber Get Order Details.

I emphasize that the scope on the dashboard is correctly configured as well as the permission grants.

"error":"invalid_scope”

What I have tried:

I have tried the scope which is on the documentation but nothing work. In postman, I put my params in the Body > x-www-form-urlencoded.
Posted
Updated 18-Jan-23 0:31am
v2
Comments
Krutov777 17-Jan-23 19:37pm    
how did you resolve the issue?
Graeme_Grant 17-Jan-23 20:06pm    
No code, so hard to tell, but I am guessing he did not use the eats.order scope.

ref: Scopes - Developers | Uber[^]
Krutov777 18-Jan-23 7:16am    
Perhaps you can help me. I can only create a token with the offline_access scope, but I need the rest of the general scopes to access the GET /estimates/price request, I tried specifying the scope in the GET parameter of the request https://login.uber.com/oauth/v2/authorize, but it gives an invalid scope error, there is no way to select scopes through the developer's dashboard. Saw such a post here: https://developer.uber.com/docs/riders/references/api/v1.2/estimates-price-get

Uber approval is required to access this API endpoint.

As part of Uber's ongoing privacy improvements, we are updating our Developer API program with new access policies for third-party apps.

To access this API, please contact your Uber Business Development Representative or Uber Contact.

It's not at all clear where to go specifically, if you know, please let me know, you will be very helpful
Graeme_Grant 18-Jan-23 16:33pm    
I do not use that API, however, "scopes" are part of the official OAuth 2.0 specification. It is all in the documentation.
[no name] 18-Jan-23 9:52am    
Hi, I would like to ask how you solved this problem

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900