Click here to Skip to main content
15,900,973 members
Please Sign up or sign in to vote.
1.00/5 (1 vote)
See more:
My client has this running (when I use @@VERSION)

Microsoft SQL Server 2017 (RTM-GDR) (KB5014354) - 14.0.2042.3 (X64) Apr 29 2022 21:04:31 Copyright (C) 2017 Microsoft Corporation Standard Edition (64-bit) on Windows Server 2012 R2 Standard 6.3 <x64> (Build 9600: )

I downloaded the latest CU and tried to install it. It told me the latest version is already installed. The latest version is KB5010786 according to MS. It won't let me update.

Why would the installation process for KB5010786 tell me that KB5010786 is already installed when clearly @@VERSION says something different?

I only have one instance of SQL 2017 running on their server.



What I have tried:

Tried installing the latest version
Updated 20-Jun-22 0:01am

This has nothing to do with writing code, which is what this site is about.

You should be contacting MS Support for SQL Server.
Share this answer
The clue is in the name: a CU is a Cumulative update.

That means if you have KB5014354[^] installed, then it already includes KB5010786[^].

5010786 was issued 30th March 2022.
5014354 was issued 14th June 2022.

The security update says that the latest version is 14.0.2042.3, which is precisely what your system is reporting.
Share this answer

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900