Click here to Skip to main content
15,907,001 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
I have been trying to digitally sign for my driver file. I have been using this on the command prompt:

C:\Program Files (x86)\Windows Kits\10\bin\10.0.22621.0\x86>signtool sign /v /fd sha1 /t http://timestamp.globalsign.com/tsa/r6advanced1 /sm Personal /n DriverMonochromator prefix.cat


Looks like anything after the /sm file is considered as FileName.

The following certificate was selected:
    Issued to: DriverMonochromator
    Issued by: DriverMonochromator
    Expires:   Sat Dec 31 16:59:59 2039
    SHA1 hash: E70F7745D8D42E9722A42E97A65DAC8039B940CF

Done Adding Additional Store
SignTool Error: File not found: Personal
SignTool Error: File not found: /n
SignTool Error: File not found: DriverMonochromator
SignTool Error: File not found: prefix.inf

Number of files successfully Signed: 0
Number of warnings: 0
Number of errors: 4


What I have tried:

How do I solve this? I have been reading bunch of article and using many other syntax but still the same error
Posted
Updated 20-Jul-22 7:09am

1 solution

You could have solved this yourself by examining the help for the sign option:
signtool sign /?

The option for picking the store you want to use is "/s Personal", not "/sm".
/s <name>   Specify the Store to open when searching for the cert. The default
            is the "MY" Store.
/sm         Open a Machine store instead of a User store.

Note, there is no name parameter for "/sm".
 
Share this answer
 
v2

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900