Click here to Skip to main content
15,906,329 members
Please Sign up or sign in to vote.
1.00/5 (1 vote)
See more:
Dear all
i am using asp.net core 3.1 i cant upload or download into database all
ASP.NET
public class Files
   {
       [Key]
       public int DocumentId { get; set; }
       public string Name { get; set; }
       public string FileType { get; set; }
      public byte[] DataFiles { get; set; }

here is my controller

ASP.NET
<pre>public class DemoController : Controller
    {
        private readonly ApplicationDbContext _context;
        public DemoController(ApplicationDbContext context)
        {
            _context = context;
        }
        public IActionResult Index()
        {
            var result = _context.Files.ToList();
            return View(result);
        }

        [HttpPost]
        public IActionResult Index(IFormFile files)
        {
            if (files != null)
            {
                if (files.Length > 0)
                {
                    //Getting FileName
                    var fileName = Path.GetFileName(files.FileName);
                    //Getting file Extension
                    var fileExtension = Path.GetExtension(fileName);
                    // concatenating  FileName + FileExtension
                    var newFileName = String.Concat(Convert.ToString(Guid.NewGuid()), fileExtension);

                    var objfiles = new Files()
                    {
                        DocumentId = 0,
                        Name = newFileName,
                        FileType = fileExtension,
                    };

                    using (var target = new MemoryStream())
                    {
                        files.CopyTo(target);
                        objfiles.DataFiles = target.ToArray();
                    }

                    _context.Files.Add(objfiles);
                    _context.SaveChanges();

                }
            }
            return View();
        }

           public IActionResult DownloadImage(int id)
       {
           byte[] bytes;
         string fileName, contentType;
        var item = _context.Files.FirstOrDefault(c => c.DocumentId == id);

             if (item != null)
          {
                   fileName = item.Name;

                  contentType = item.FileType;
                  bytes = item.DataFiles;
                  return File(bytes, contentType, fileName);
               }
             return Ok("Can't find the File");
            }      
    }
}

here is my view

ASP.NET
<pre>@model List<Info.Models.Files>
@{
    ViewData["Title"] = "Index";
}

<h1>Index</h1>
<div class="row">
    <div class="col-md-5">
        <form method="post" enctype="multipart/form-data" asp-controller="Demo" asp-action="Index">
            <div class="form-group">
                <div class="col-md-10">
                    <p>Upload file</p>
                    <input class="form-control" name="files" type="file" />
                </div>
            </div>
            <div class="form-group">
                <div class="col-md-10">
                    <input class="btn btn-success" type="submit" value="Upload" />
                </div>
            </div>
        </form>
    </div>
</div>
<ul>
    @foreach (var item in Model)
    {
        <li>
            <a asp-action="DownloadImage"
               asp-route-filename="@item.Name">
                @item.Name
            </a>
        </li>
    }
</ul>


What I have tried:

i want to save files into database and display its URl so i can download it
Posted
Updated 2-Dec-22 2:05am
Comments
Dave Kreskowiak 2-Dec-22 8:50am    
Which line throw the error?

1 solution

This is one of the most common problems we get asked, and it's also the one we are least equipped to answer, but you are most equipped to answer yourself.

Let me just explain what the error means: You have tried to use a variable, property, or a method return value but it contains null - which means that there is no instance of a class in the variable.
It's a bit like a pocket: you have a pocket in your shirt, which you use to hold a pen. If you reach into the pocket and find there isn't a pen there, you can't sign your name on a piece of paper - and you will get very funny looks if you try! The empty pocket is giving you a null value (no pen here!) so you can't do anything that you would normally do once you retrieved your pen. Why is it empty? That's the question - it may be that you forgot to pick up your pen when you left the house this morning, or possibly you left the pen in the pocket of yesterday's shirt when you took it off last night.

We can't tell, because we weren't there, and even more importantly, we can't even see your shirt, much less what is in the pocket!

Back to computers, and you have done the same thing, somehow - and we can't see your code, much less run it and find out what contains null when it shouldn't.
But you can - and Visual Studio will help you here. Run your program in the debugger and when it fails, it will show you the line it found the problem on. You can then start looking at the various parts of it to see what value is null and start looking back through your code to find out why. So put a breakpoint at the beginning of the method containing the error line, and run your program from the start again. This time, the debugger will stop before the error, and let you examine what is going on by stepping through the code looking at your values.

But we can't do that - we don't have your code, we don't know how to use it if we did have it, we don't have your data. So try it - and see how much information you can find out!
 
Share this answer
 
Comments
hany mohamed 2021 2-Dec-22 8:48am    
My Dear thanks for your rplay the error is in the index view
@foreach (var item in Model)
but i cant solve it
and i have already sent all codes
Dave Kreskowiak 2-Dec-22 9:40am    
If that's the line throwing the error, the Model you sent to the view, with a return View() statement didn't send anything or sent null because a variable you tried to send was null.
OriginalGriff 2-Dec-22 10:29am    
You'd think that once you suggest using the debugger to look at what is actually going on, they might just possibly work out "oh, that's null - I wonder why" for themselves, but it seems that is beyond most of 'em. :sigh:
Dave Kreskowiak 2-Dec-22 10:36am    
I know, right?!

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900