Click here to Skip to main content
15,881,812 members
Please Sign up or sign in to vote.
1.00/5 (1 vote)
See more:
Hello,
I'm using an rpi pico-w as a tcp client in a logging project (written in 'C'). By copying the examples, the code is running. After successfully communicating a number of times the "tcp_client_open" function fails when "tcp_new_ip_open" returns with zero. I'm not sure what the function does, and can find no documentation describing reasons for failure. Please could somebody point me to documentation?

What I have tried:

Repeating the "open" fails consistently unless a delay of 2 seconds or more is introduced, when it sometimes recovers; it does not appear to be running out of memory.
Posted
Updated 18-Jan-23 5:10am

1 solution

Quote:
Please could somebody point me to documentation
The documentation, if it exists, is likely to come from the same place that the code came from. But we don't know where that is, since you have not said where you got it.
 
Share this answer
 
Comments
Les Wilkinson 19-Jan-23 5:07am    
Funnily enough I checked there. The example came from "https://github.com/raspberrypi/pico-examples/blob/master/pico_w/tcp_client/picow_tcp_client.c" although it appears in the RPi site as well. The function in question is at line 172.
Richard MacCutchan 19-Jan-23 5:48am    
Line 172 really does not tell us anything, so you have two choices:
1. Try to debug the code yourself.
2. Contact the person who wrote it to find out why that call fails.
Les Wilkinson 19-Jan-23 9:23am    
Thanks anyway
Le. W.

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900