Click here to Skip to main content
15,908,674 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
Hello,
I'm new to xampp and mySQL and i'm getting an error that reads. I'm trying to run a simple Hello world php file from the localhost

HTTP Error 404.3 - Not Found
The page you are requesting cannot be served because of the extension configuration. If the page is a script, add a handler. If the file should be downloaded, add a MIME map.


Most likely causes:
It is possible that a handler mapping is missing. By default, the static file handler processes all content.
The feature you are trying to use may not be installed.
The appropriate MIME map is not enabled for the Web site or application. (Warning: Do not create a MIME map for content that users should not download, such as .ASPX pages or .config files.)
If ASP.NET is not installed.


What I have tried:

installing ASP.NET
looking for MIME files?
Posted
Updated 9-Feb-23 19:23pm

1 solution

As per your error, when you get the 404.3 error, you should know that there is a MIME restriction and the handler needed for it is missing. If the images or videos are not loading, then the required MIME-type is not available. The error can also surface if ASP.NET feature is not enabled.

There are 3 ways to resolve the error -
1. Install ASP.NET feature
2. Adding a Script Handler in your IIS Manager (Internet Information Services)
3. Select MIME type (Multipurpose Internet Mail Extensions)

Fixing the 404.3 HTTP Error: A Complete Guide[^] hosts the detailed steps on how to achieve the above.
 
Share this answer
 
v2

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900