Click here to Skip to main content
15,878,316 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
why do i get this error when i try to install pip packages.
even though pip is installed on my computer.
i would really appreciate some help.

here is the error:

(venv) PS C:\Users\user\PycharmProjects\pythonProject> pip install pywhatkit
Traceback (most recent call last):
  File "<frozen runpy="">", line 198, in _run_module_as_main                                                                            
  File "<frozen runpy="">", line 88, in _run_code                                                                                       
  File "C:\Users\user\PycharmProjects\pythonProject\venv\Scripts\pip.exe\", line 4, in <module>                           
  File "C:\Users\user\PycharmProjects\pythonProject\venv\Lib\site-packages\pip\_internal\cli\", line 9, in <module>           
    from pip._internal.cli.autocompletion import autocomplete                                                                        
  File "C:\Users\user\PycharmProjects\pythonProject\venv\Lib\site-packages\pip\_internal\cli\", line 10, in <module>
    from pip._internal.cli.main_parser import create_main_parser                                                                     
  File "C:\Users\user\PycharmProjects\pythonProject\venv\Lib\site-packages\pip\_internal\cli\", line 9, in <module>    
    from pip._internal.build_env import get_runnable_pip                                                                             
  File "C:\Users\user\PycharmProjects\pythonProject\venv\Lib\site-packages\pip\_internal\", line 20, in <module>         
    from pip._internal.cli.spinners import open_spinner
  File "C:\Users\user\PycharmProjects\pythonProject\venv\Lib\site-packages\pip\_internal\cli\", line 9, in <module>
    from pip._internal.utils.logging import get_indentation
  File "C:\Users\user\PycharmProjects\pythonProject\venv\Lib\site-packages\pip\_internal\utils\", line 13, in <module>
    from import (
  File "C:\Users\user\PycharmProjects\pythonProject\venv\Lib\site-packages\pip\_vendor\rich\", line 49, in <module>
    from ._log_render import FormatTimeCallable, LogRender
  File "C:\Users\user\PycharmProjects\pythonProject\venv\Lib\site-packages\pip\_vendor\rich\", line 5, in <module>
    from .text import Text, TextType
  File "C:\Users\user\PycharmProjects\pythonProject\venv\Lib\site-packages\pip\_vendor\rich\", line 21, in <module>
    from .align import AlignMethod
  File "C:\Users\user\PycharmProjects\pythonProject\venv\Lib\site-packages\pip\_vendor\rich\", line 10, in <module>
    from .constrain import Constrain
  File "C:\Users\user\PycharmProjects\pythonProject\venv\Lib\site-packages\pip\_vendor\rich\", line 3, in <module>
    from .jupyter import JupyterMixin
ModuleNotFoundError: No module named ''

What I have tried:

i have tried reinstalling python and installing or upgrading pip
Richard MacCutchan 28-Mar-23 4:36am    
The error message suggests that you have not installed the Jupyter system.
Richard MacCutchan 28-Mar-23 4:40am    
I just installed pywhatkit with no problems, so i can only assume the problem is in your environment.

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900