Click here to Skip to main content
15,916,842 members
Please Sign up or sign in to vote.
1.00/5 (2 votes)
See more:
I have a Sewoo LK-B425A Printer, I have connected it to my PC via USB cable. At the first time plug in, there is no anything in Devices and Printers. Then I unplug the USB and install the divers by CD disk (which included with the printer), after that SEWOO Label Printer display at Printers and also display at Printer queues in Device Manager. Next, I plug the USB again and it shows up as unspecified device as the picture below. Currently if I unplug the USB, LK-B425 device will disappear and I can't print. I only can print if both of devices LK-B425 and SEWOO Label Printer are exist.

Please help me to fix it.

Devices and Printers

What I have tried:

I tried to unintall device and re-install the driver but issue is not fixed
Posted
Updated 12-Apr-23 21:46pm

1 solution

This is not a Windows (or Sewoo) tech support site: we are here for software development problems and support.

You need to contact the printer manufacturers via their tech support - they will be familiar with their product and brand (which I for one have never even heard of). You should find the website on the packaging or in the manual.
 
Share this answer
 
v2

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900