Click here to Skip to main content
15,921,622 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
Hi From few days i have been trying to make the facial recognition to run, but unsuccessfully.
The configuration on which i am running is i5-6500 with 16 gig ram, ver. 2.1.8, windows 10 home. The installed modules are YOLOv5 .NET and facial recognition. With the previous version i did not have such problems.

The object detection works, but when i try to recognize a face in the explorer it returns the following error:

"unable to process the request

KeyError: 'error'

07:49:00:Face Processing:  [FileNotFoundError] : Traceback (most recent call last):
  File "C:\Program Files\CodeProject\AI\modules\FaceProcessing\intelligencelayer\face.py", line 160, in init_models
    cuda=SharedOptions.USE_CUDA)
  File "C:\Program Files\CodeProject\AI\modules\FaceProcessing\intelligencelayer\.\recognition\process.py", line 28, in __init__
    load_model(self.model, model_path)
  File "C:\Program Files\CodeProject\AI\modules\FaceProcessing\intelligencelayer\.\recognition\process.py", line 11, in load_model
    checkpoint = torch.load(path, map_location=lambda storage, loc: storage)
  File "C:\Program Files\CodeProject\AI\runtimes\bin\windows\python37\venv\lib\site-packages\torch\serialization.py", line 594, in load
    with _open_file_like(f, 'rb') as opened_file:
  File "C:\Program Files\CodeProject\AI\runtimes\bin\windows\python37\venv\lib\site-packages\torch\serialization.py", line 230, in _open_file_like
    return _open_file(name_or_buffer, mode)
  File "C:\Program Files\CodeProject\AI\runtimes\bin\windows\python37\venv\lib\site-packages\torch\serialization.py", line 211, in __init__
    super(_open_file, self).__init__(open(name, mode))
FileNotFoundError: [Errno 2] No such file or directory: 'C:\\Program Files\\CodeProject\\AI\\modules\\FaceProcessing\\assets\\facerec-high.model'
07:49:00:Face Processing:  [KeyError] : Traceback (most recent call last):
  File "../../SDK/Python\module_runner.py", line 503, in main_loop
    output = await callbacktask
  File "C:\Program Files\CodeProject\AI\runtimes\bin\windows\python37\lib\concurrent\futures\thread.py", line 57, in run
    result = self.fn(*self.args, **self.kwargs)
  File "C:\Program Files\CodeProject\AI\modules\FaceProcessing\intelligencelayer\face.py", line 135, in process
    message = output["error"]
KeyError: 'error'



Thanks in advance

What I have tried:

I have tried reinstalling.
Tried "disable GPU" command.
Posted
Updated 22-May-23 19:01pm

You have to install also Deepstack, then copy files from C:\DeepStack\sharedfiles to C:\Program Files\CodeProject\AI\modules\FaceProcessing\assets.
 
Share this answer
 
v2
Probably the best place to ask this is the dedicated forum: CodeProject.AI Discussions[^]
 
Share this answer
 

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900