Click here to Skip to main content
15,884,388 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
I'm running Ubuntu 22.04.2 LTS and have dual boot windows 11. I'm trying to hide grub menu while booting and automatically boot ubuntu as I have seen that can be done with changing GRUB_TIMEOUT to 0 in /etc/default/grub and run sudo update-grub but grub doesn't hide and sets time to 10 seconds. I am able to change the timer to be different even -1 but 0 does not work for whatever reason.

What I have tried:

I have also come across the solution that in /etc/grub.d/40_custom I should add at the end of the file: set default="0" set timeout=0 . While this works I'm concerned that when some error occurs I would not be able to get into ubuntu advanced options because it disables grub menu in the boot time so I decided not to use it.

Here is my /etc/default/grub: GNU nano 6.2 /etc/default/grub

If you change this file, run 'update-grub' afterwards to update
/boot/grub/grub.cfg.
For full documentation of the options in this file, see:
info -f grub -n 'Simple configuration'
GRUB_DEFAULT=0 GRUB_TIMEOUT_STYLE=hidden GRUB_TIMEOUT=0 GRUB_DISTRIBUTOR=lsb_release -i -s 2> /dev/null || echo Debian GRUB_CMDLINE_LINUX_DEFAULT="quiet splash loglevel=0" GRUB_CMDLINE_LINUX=""

Uncomment to enable BadRAM filtering, modify to suit your needs
This works with Linux (no patch required) and with any kernel that obtains
the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

The resolution used on graphical terminal
note that you can use only modes which your graphic card supports via VBE
you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1" GRUB_DISABLE_OS_PROBER=false

I would be really grateful for any advice as to why my grub menu does not hide. Thank you in advance
Posted

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
Top Experts
Last 24hrsThis month


CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900