Click here to Skip to main content
15,904,494 members
Please Sign up or sign in to vote.
1.00/5 (1 vote)
See more:
Hi All,
Bit of an odd one, I have written a quick little app in VS 2008 (.NET2), I brought it into work to make my life easier. The 'thing!' won't run with or without admin rights on Win 11. Possible issues I can think of:

1) Virus Control (Not aware of any)
2) Differences is machine (.NET should handle that, it has in the past)
3) Insufficient rights (but I'm a local Admin!)
4) VS2008 not advanced enough for Win11 (I have used other programs built with it)

Windows ignores a click on the Icon??

Umm is there a setting I am missing or ....

What I have tried:

Running Exe by double clicking also tried to run via Run as Admin.
Posted
Updated 26-Jul-23 4:42am
Comments
Graeme_Grant 26-Jul-23 8:31am    
You know that we can't see your code on your PC ... Same with the error messages.

There is not enough information to know what is going on.
glennPattonWork3 26-Jul-23 8:49am    
Thats the thing, I click nothing happens! I'm wondering if it's some to with a .NET2 program running on Win11...
Graeme_Grant 26-Jul-23 8:54am    
It's like you're saying over the phone that your car won't start. If I can't see it, nor hear it, how am I supposed to identify the issue?
glennPattonWork3 26-Jul-23 9:39am    
All I can say is I click on the Icon doesn't open (slows right down) doesn't open I don't have any tools to do a more in-depth analysis. I was just wondering if there was a known issue.
CHill60 26-Jul-23 8:52am    
Have you tried rebuilding it on that machine?
Included any libraries that may not be standard?
Not used anything that is now deprecated? (Saw someone the other day wondering why his code stopped working on WIN11 and he was trying to open Internet Explorer)
Where are you running it from?
Have you discussed this with your local IT team (thinking group policies may have changed?)

Solved it! Running on a machine with No Serial Ports...Runs fine with Serial Ports Stupid!!
 
Share this answer
 
Comments
OriginalGriff 26-Jul-23 15:01pm    
Ha! Had to be something fairly obvious - and easy to miss.
Well done!
glennPattonWork3 26-Jul-23 15:43pm    
A simple error message would have save so much time.
We can't help you - we don't have any way to examine the app or the system it is running on.

My first check would be to look at how you "brought it into work" - did you just copy the EXE file, or did you copy the whole bin/Release folder? Did you make an installer? Are the config files present? Are dependent assemblies installed where needed or present in the EXE folder?
Where did you put the exe before you ran it?

Then I'd be looking at local policies: do IT have any group policies which prevent some apps / assemblies running?

Does it work on a different machine in the same office?

I think there is a good chance you're going to have to disturb the IT department on this one!
 
Share this answer
 
Comments
glennPattonWork3 26-Jul-23 10:41am    
Took the whole project file. There are any config files as it is a serial port program. I will try something, I might have an idea...

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900